Forum Stats

  • 3,816,076 Users
  • 2,259,137 Discussions
  • 7,893,388 Comments

Discussions

Oracle Studio 12.6 install seems broken? pkg version conflicts?

After carefully following steps on various pages ( see https://docs.oracle.com/cd/E77782_01/html/E77785/gozsz.html ) where I was given a certificate and a key for the Solaris Studio IPS repo "solarisstudio" I am told there are version conflicts in packages. I did run the correct "pkg set-publisher" command to accept the certificate and key and that results in copies being left in the /var/pkg/ssl directory. However any attempt to install developerstudio-126 throws a bucket of errors :

spartacus#

spartacus# pkg install --accept developerstudio-126

Creating Plan (Running solver): /

pkg install: No matching version of developer/developerstudio-126 can be installed:

 Reject: pkg://solarisstudio/developer/[email protected]

 Reason: No version matching 'require' dependency developer/developerstudio-126/[email protected],5.11-1.0.0.0 can be installed

   ----------------------------------------

   Reject: pkg://solarisstudio/developer/developerstudio-126/[email protected]

   Reason: No version matching 'require' dependency system/library/[email protected],5.11-0.175.3.13.0.1.0 can be installed

     ----------------------------------------

     Reject: pkg://solaris/system/library/[email protected]

                to

              pkg://solaris/system/library/[email protected]

     Reason: This version is excluded by installed incorporation consolidation/sunpro/[email protected]

     ----------------------------------------

   Reject: pkg://solarisstudio/developer/developerstudio-126/[email protected]

   Reason: No version matching 'require' dependency developer/developerstudio-126/library/[email protected],5.11-1.0.0.1 can be installed

     ----------------------------------------

     Reject: pkg://solarisstudio/developer/developerstudio-126/library/[email protected]

     Reason: No version matching 'require' dependency system/library/[email protected],5.11-0.175.3.13.0.1.0 can be installed

     ----------------------------------------

   ----------------------------------------

 Reject: pkg://solarisstudio/developer/[email protected]

 Reason: No version matching 'require' dependency developer/developerstudio-126/[email protected],5.11-1.0.0.1 can be installed

spartacus#

See file attached.


What is the magic needed ?