Forum Stats

  • 3,816,600 Users
  • 2,259,212 Discussions
  • 7,893,516 Comments

Discussions

How to serve forms through ohs1 instead of wls_forms

juliojgs
juliojgs Member Posts: 580 Bronze Badge
edited Apr 28, 2022 3:52PM in Forms

Hi.

We are testing migration from 11g to 12.2.1.4 on linux.

After installation and configuration of weblogic, wls_forms, wls_reports, a standalone reports server and ohs1, I have forms running on port 9001 and reports on 9002.

I would like to know how to make ohs1 component to serve forms, instead of (or besides) wls_forms

Thanks.

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 7,136 Employee
    edited Apr 28, 2022 4:29PM

    You can manually wire OHS to Forms, the easiest way is to use the Forms Helper Script (if you are using v12)

    https://docs.oracle.com/en/middleware/developer-tools/forms/12.2.1.4/working-forms/configuring-and-managing-forms-services.html#GUID-C2BE12FA-450C-4CF7-983C-8AE2C4FFBF02

    Running this will create a proper "forms.conf" file for you. Once created, you will be able to edit it in Fusion Middleware Control.



    Michael Ferrante

    Senior Principal Product Manager

    Oracle

    Twitter: @OracleFormsPM

  • juliojgs
    juliojgs Member Posts: 580 Bronze Badge

    Thanks.

    I ran the command:

    frmconfighelper.cmd enable_ohs C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain ohs1 localhost 9001

    The forms.conf file appeared in the filesystem, at location:

    C:\Oracle\Middleware\Oracle_Home\user_projects\domains\base_domain\config\fmwconfig\components\OHS\ohs1\moduleconf

    But it doesn't show in the middleware control:

    The uncommented content of the forms.conf file is

    #   
    # entries added by formsconfighelper script   
    #   
    <Location /forms/>  
            SetHandler weblogic-handler  
            WebLogicCluster localhost:9001  
            DynamicServerList OFF    
       
    #   
    # If SSL is enabled in a proxy in front of WLS (e.g. OHS)   
    # then you must set WLSProxySSL ON (uncomment the WLProxySSL entry below).   
    #   
    # Be sure to also set WebLogic Plugin Enable to YES    
    # in the WebLogic Console in the managed server's   
    # General Advanced settings.   
    #   
    # WLProxySSL ON   
       
    </Location> 
    
    

    I'm being able to run forms with ohs1 down, so I supose it is WLS_FORMS who is serving them.

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 7,136 Employee
    edited May 11, 2022 3:33PM

    To be clear, WLS will always "serve" Forms (and Reports). Using OHS simply is a proxy (front-end) to WLS. That said, after you run the Forms Helper Script, bounce the servers (including OHS). Once you properly get forms.conf in place, you would access your application using the OHS port. Note that just because you did this does not mean the app will no longer be accessible via the WLS port; it will. If you want to block the WLS port you need to do something additional which is unrelated to Forms.



    Michael Ferrante

    Senior Principal Product Manager

    Oracle

    Twitter: @OracleFormsPM

  • juliojgs
    juliojgs Member Posts: 580 Bronze Badge

    ok, so running the frmconfighelper with the same port 9001 is nonsense, as this is the port WLS is already using to serve forms.

    I should've chosen another port.

    Anyway ... isn't it weird that forms.conf file doesn't appear in fusion middleware list?

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 7,136 Employee

    After running the Helper utility you must stop the servers (e.g. Admin Server, WLS_FORMS, OHS, etc) then restart them. This assumes you successfully ran the script, meaning it did not fail when you ran it.

    https://docs.oracle.com/en/middleware/developer-tools/forms/12.2.1.4/working-forms/configuring-and-managing-forms-services.html#GUID-C2BE12FA-450C-4CF7-983C-8AE2C4FFBF02

    Regarding your comment about the Helper script and the use of 9001, you have to pass in "9001" or whatever port you used for the managed server because that information is added to forms.conf so OHS knows how to find WLS_FORMS.


    Michael Ferrante

    Senior Principal Product Manager

    Oracle

    Twitter: @OracleFormsPM