Forum Stats

  • 3,816,408 Users
  • 2,259,185 Discussions
  • 7,893,475 Comments

Discussions

Can't get sqlldr.exe running on new Windows 10 machine

Brian Leahy
Brian Leahy Member Posts: 10 Red Ribbon
edited May 12, 2022 9:34PM in Database Installation

I have followed the instructions I've found online (detailed below) to accomplish this, and still I get:

...followed by identical errors for oranls.dll, oracore.dll and oraxml.dll.

This is for a user PC, I need sqlldr.exe running, but the database is not local.

What I have tried:

I downloaded all these files:

instantclient-basiclite-windows.x64-21.3.0.0.0.zip            

instantclient-tools-windows.x64-21.3.0.0.0.zip

instantclient-sqlplus-windows.x64-21.3.0.0.0.zip

I unzipped all of them into C:\Oracle\instantclient_21_3

Edited my Path environment variable to include C:\Oracle\instantclient_21_3 - both the user's Path and the "System" Path.

Created environment variable TNS_ADMIN to point to directory C:\Oracle\tns_admin in which I have these (certified correct) files:

ldap.ora

sqlnet.ora

tnsnames.ora

I downloaded and ran vs_redistx64.exe (visual studio redistributable) and rebooted the PC.

Still, when I go to C:\Oracle\instantclient_21_3 and execute .\sqlldr.exe (with no arguments) I get the above error messages "The code execution cannot proceed..." etc. Instead, I should at least get the text telling me how to use sqlldr.exe

This machine won't be used for development, and I would prefer not to install SDKs, let alone an actual database, onto the local machine if I can avoid it.

Can someone help?

Answers

  • Brian Leahy
    Brian Leahy Member Posts: 10 Red Ribbon

    I did ultimately get it to work. I think the problem related to how I unzipped the files; the first time I unzipped the (19, not 21) Instant Client files, I believe I did it in such a way that the zip's subdirectories were not created properly on my C: volume.

    When I did a vanilla command line "unzip" of the file, they were. The odd part is that sqlldr works now - but the dlls it previously asked for (oranls.dll, oracore.dll and oraxml.dll) are still nowhere to be seen. Weird. 🤷‍♂️