Forum Stats

  • 3,816,079 Users
  • 2,259,137 Discussions
  • 7,893,389 Comments

Discussions

Chinese Character Not Readable Using REST Method

User_VXRBO
User_VXRBO Member Posts: 3 Red Ribbon

My database language type NLS_CHARACTERSET is US7ASCII. I'm created REST Service in Apex and to insert the data into my custom table without issue. Now the problem is my posted JSON data with Chinese character and is not readable and it shown "?".

I did changed my table structure to nvarchar2 and using SQL developer to run the following syntax and it success, I'm able to read the Chinese character.

  • insert into test_table (f1) values (N'测');

Now my question is whether in Apex I can use same method ? I had tried in Apex using following syntax, but it does not worked. Appreciate for help.

  • insert into test_table (f1) values (N':item_desc);
  • insert into test_table (f1) values (N'':item_desc);

Thanks in advance.

Answers

  • Mike Kutz
    Mike Kutz Member Posts: 6,189 Silver Crown
    edited May 14, 2022 2:19PM

    My database language type NLS_CHARACTERSET is US7ASCII

    I suspect that multibyte characters are unsupported when using a DB with NLS_CHARCTERSET=US7ASCII.

    AFAIK - That 8th bit (which those charcters require) is allowed to be dropped.

    APEX transfers data using VARCHAR2, not NVARCHAR2.

    Upgrade to something supports those characters: AL32UTF8

  • User_VXRBO
    User_VXRBO Member Posts: 3 Red Ribbon

    Thanks Mike for advise.

    Performing DB upgrade to support characters: AL32UTF8 will be huge effort as this DB is same as my Oracle EBS R12. Looking for any other alternate option before consider DB character upgrade.