Forum Stats

  • 3,872,222 Users
  • 2,266,407 Discussions
  • 7,911,107 Comments

Discussions

Facing issue with ORDS http/https

Hi,

current setup:

RHEL-8.5 with ORDS 21.4.3.117.0405, APEX 20.2 and Apache (httpd) installed. No Tomcat. We created own certificates for ssl (server is running in intranet only). I can access the APEX backend via https://ourdomain.biz/ords and can create an APEX app.

As soon as I click on the "Run" button the app opens in another tab but the browser shows me:

This page isn’t working right now

ourdomain.biz redirected you too many times.

If I set "Rejoin Sessions" in the application settings to "Enabled for Public Session" the app opens but without ssl. I have to change the URL from http://ourdomain.biz/ords/workspace/r/app/login to https://ourdomain.biz/ords/workspace/r/app/login manualy.

For testing I installed the productivity app "Sample Dynamic Actions" with the same behavior.

Here are the config files from the server:

ORDS defaults.xml

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">

<properties>

<comment>Saved on Mon May 09 16:21:49 CEST 2022</comment>

<entry key="database.api.enabled">true</entry>

<entry key="db.connectionType">basic</entry>

<entry key="db.hostname">xxx.biz</entry>

<entry key="db.port">1521</entry>

<entry key="db.servicename">aaa</entry>

<entry key="feature.sdw">true</entry>

<entry key="restEnabledSql.active">true</entry>

<entry key="security.requestValidationFunction">wwv_flow_epg_include_modules.authorize</entry>

<entry key="security.validationFunctionType">plsql</entry>

<entry key="security.forceHTTPS">true</entry>

<entry key="jdbc.InitialLimit">0</entry>

<entry key="jdbc.MinLimit">0</entry>

<entry key="jdbc.MaxLimit">50</entry>

<entry key="cache.metadata.enabled">true</entry>

<entry key="jdbc.InactivityTimeout">1800</entry>

</properties>


ORDS standalone.properties

#Mon May 09 16:23:43 CEST 2022

jetty.port=8080

standalone.context.path=/ords

standalone.doc.root=/opt/apex/config/ords/standalone/doc_root

standalone.scheme.do.not.prompt=true

standalone.static.context.path=/i

standalone.static.do.not.prompt=true


httpd conf for ssl:

<VirtualHost *:80>

ServerName moldev.emea.adsint.biz

#Redirect / https://localhost/

Redirect / https://ourdomain.biz/

</VirtualHost>

<VirtualHost *:443>

ServerName ourdomain.biz

RewriteEngine on

ProxyPreserveHost On

RequestHeader unset Origin

SSLEngine on

SSLCertificateFile /opt/apex/cert/ourdomain.biz.cer

SSLCertificateKeyFile /opt/apex/cert/ourdomain.biz.key

SSLCACertificateFile /opt/apex/cert/ourdomain.biz.crt

ProxyPass /ords http://localhost:8080/ords timeout=1800

ProxyPassReverse /ords http://localhost/ords

ProxyPreserveHost On

</VirtualHost>


ords.service

[Unit]

Description=ORDS

After=network.target

[Service]

Type=simple

User=ords

Group=ords

Environment=WS_HOME=/opt/apex/latest

Environment=WS_PROCESS_NAME=ORDS

Environment=WS_EXECUTABLE_NAME=server-linux

Environment=PATH=/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/bin/

Environment=HOME=/opt/apex/latest

SyslogIdentifier=ords

Restart=always

RestartSec=30

TimeoutStartSec=30

TimeoutStopSec=30

WorkingDirectory=/opt/apex/latest

ExecStart=/usr/bin/java "-Dorg.eclipse.jetty.server.Request.maxFormContentSize=3000000" -jar ords.war standalone

ExecStop=kill $(ps -ef | grep "ords.war" | grep -v grep| awk '{print $2}')

[Install]

WantedBy=multi-user.target


Any idea what's wrong? If you need more details please let me know.

Tagged:

Answers