Forum Stats

  • 3,826,356 Users
  • 2,260,634 Discussions
  • 7,896,915 Comments

Discussions

Is Struts supported in ADF/Jdeveloper 12.2?

Hello?

I saw Struts Runtime is deprecated in Jdeveloper 12c from the following link.

But the above link is applied for 12.1.2 and 12.1.3

I am not sure Struts Runtime is supported in 12.2 version with deprecated features like 12.1.3/12.1.2

Thanks,

Jonghyeon.

Answers

  • dvohra21
    dvohra21 Member Posts: 14,573 Gold Crown

    If 12.1 deprecated Struts, 12.2 probably removed Struts. Likely to get:

    The target struts-config.xml cannot be started because it is not a runnable target.
    
  • Timo Hahn
    Timo Hahn Senior Principal Technical Consultant - Oracle ACE Director Member, Moderator Posts: 38,457 Red Diamond

    The question is what do you try to archive?


    You can add the streets runtime and other stuff jars to you project. However, the is no help building a struts based application using JDev 12c. You have to everything by hand yourself.


    The next question is how to run the application on the server. I'm sure it can be done but again no help from this community out JDev.


    Timo

  • dvohra21
    dvohra21 Member Posts: 14,573 Gold Crown
    edited Jun 18, 2022 4:10PM

    If the Apache Struts 2 framework has to be used why not use JDev 12.1? 12.2 definitely does not offer any Struts-related additional benefits.