Forum Stats

  • 3,854,249 Users
  • 2,264,344 Discussions
  • 7,905,621 Comments

Discussions

database is open but can't sqlplus into it

User_JS9UL
User_JS9UL Member Posts: 1 Green Ribbon

I have upgrade db from 12 to 19c. All successful and when I applied April 2022 patch, OJVM was fine but DB patch successful for 158 minutes. The problem is db open but can't sqlplus into it. it's idle instance. I checked the status, crsctl stat res -t and target of ora.ons OFFLINE OFFLINE and ora.dbname.db ONLINE INTERMEDIATE.

I tried to force to shutdown and restart the database via srvctl command. After db start, I checked the status and it hung for quite long... after that, the sqlplus is still idle instance. According to the alert that after the DATABASE OPEN, something goes wrong with ORA-00445: background process "W004" and "CL00" did not start after 120 second. After that Unable to obtain current patch information due to error: 20001, ORA-20001: Latest xml inventory is not loaded into table: ORA-06512 at "SYS.DBMS_QOPATCH", line 2327, line 854, 937, 932. ORA-06510: PL/SQL: unhandled user-defined exception. ORA-29913: error in executing ODCIEXTTABLEFETCH callout. ORA-29400: data cartridge error. KUP-04095: preprocessor command $ORACLE_HOME/QOPatch/qopiprep.cat encountered error "pipe read timeout". ORA-06512: at "SYS.DBMS_QOPATCH", line 919, 2286, 817, 2309. It tries delete the shared memory segments from previous instance incarnation before starting the instance. and still error ORA-00445: background process "CL00" did not start after 120 second.

ASMB has not responded for 193 seconds

NOTE: ASMB umbilicus running slower than expected. heavy swapping observed on system in last 5 mins.

I tried to run dispatch and still didn't help. Would like to roll back the patchset. When I run roothas.sh -unlock it took 15 minutes to unlock. After rollback all OJVM and RU patchset, I reboot the server and nothing is come back up. Unable to connect to Cluster Synchronization Service, "has" daemon is up but could not contact Oracle High Availability Service.

What do I need to do to resolve this problem to start asm and db?

this is not RAC node but single instance running on diskgroup.

Answers