Forum Stats

  • 3,837,263 Users
  • 2,262,245 Discussions
  • 7,900,240 Comments

Discussions

lb genobject -expComponents for APEX app

User_M6NMC
User_M6NMC Posts: 3 Employee

Hi Team

I'm trying to use the -expComponents option for lb genobject but I'm getting bellow error message. I was wondering if this is a bug or if I'm not using this command correctly. I have test this command on version 22.2 and 21.4.1

----------------------------------------------------

SQLcl command:

lb genobject -type apex -applicationid 101 -split -expComponents PAGE:2 PAGE:1


Exporting Application 101

ORA-20001: Invalid TYPE:ID pair: null

ORA-06512: at "APEX_210200.WWV_FLOW_EXPORT_API", line 117

ORA-06512: at "APEX_210200.WWV_FLOW_EXPORT_INT", line 206

ORA-06512: at "APEX_210200.WWV_FLOW_EXPORT_API", line 70

ORA-06512: at line 2

----------------------------------------------------


Previously I got the component's Id using the -list option for lb genobject

----------------------------------------------------

SQLcl command:

lb genobject -type apex -applicationid 101 -list -changesSince 2022-07-19


--Starting Liquibase at 13:37:23 (version 4.9.1 #0 built at 2022-05-03 17:23+2221)

2022-07-19 16:58 PAGE:2       2. Description Report

2022-07-19 17:53 PAGE:1        1. Home

Date        ID                 Name

---------------- ---------- -----------------------

----------------------------------------------------


I have Followed this documentation: https://docs.oracle.com/en/database/oracle/sql-developer-command-line/22.2/sqcug/using-liquibase.html#GUID-B44D11C5-E444-4B06-98CF-0AB9F0CB29E6


I appreciate your help on this.

Thanks.