Forum Stats

  • 3,839,047 Users
  • 2,262,441 Discussions
  • 7,900,839 Comments

Discussions

Warning while migrating from ORDS 21.4 to ORDS 22.2 - ords migrate config

Good Afternoon,

Migrating from ORDS 21.4 to ORDS 22.2

Does anyone know how or whether it's necessary to address the following warning output I received when running the `ords migrate config` command.

The tool says certain settings aren't recognized even though they have been working in 21.4 and ORDS 22 docs suggest they are still valid.


The primary concern is this setting not being recognized. The setting was still migrated to my_pool/pool.xml successfully despite the warning.

  • The setting named: security.requestAuthenticationFunction is not a recognized configuration setting. Run: ords config info to get a list of known configuration settings
  • The setting named: security.requestAuthenticationFunction was set to: owa_custom.authorize in configuration: my_pool

Documentation suggest security.requestAuthenticationFunction hasn't been removed

https://docs.oracle.com/en/database/oracle/oracle-rest-data-services/22.2/orddg/migrating-mod_plsql-ords.html#GUID-C10DBB78-6C7A-4E2E-ADC2-3D24F087C031


There are additional warnings noted below of less importance, but I'd also like to ensure these won't cause problems. These settings were also migrated to the global/settings.xml successfully despite the warnings

  • The setting named: debug.debugger is not a recognized configuration setting. Run: ords config info to get a list of known configuration settings
  • The global setting named: debug.debugger was set to: true
  • The setting named: log.logging is not a recognized configuration setting. Run: ords config info to get a list of known configuration settings
  • The global setting named: log.logging was set to: true


Can these warnings safely be ignored?

Thanks!