Forum Stats

  • 3,853,259 Users
  • 2,264,199 Discussions
  • 7,905,296 Comments

Discussions

Unable to create the app

User_4Y93Z
User_4Y93Z Member Posts: 2 Red Ribbon

c:\node12>ojet create myfridayapp9 --template=navbar

Processing template: navbar

Error: Error: Command failed: npm install @oracle/[email protected]~10.1.0


c:\node12>npm list -g --depth=0

c:\node12

+-- @oracle/[email protected]

+-- @oracle/[email protected]

`-- [email protected]



c:\node12>npm -version

6.14.5


c:\node12>ojet -version

Oracle JET Command Line Interface, version: 10.1.0

How to proceed in this?

Answers

  • Please upgrade to a support version of Nodejs and try again. Nodejs v12 reached End of Life in April of this year. LTS v14 or higher is required.

    You should also be aware that JET v10 is not supported. JET v13.0.x is the current production release with v12 and v11 supported (v11 will hit EOL in January).