Forum Stats

  • 3,874,178 Users
  • 2,266,677 Discussions
  • 7,911,757 Comments

Discussions

MySQL workbench rpm installation failing for dependencies

Hi,


I am unable to install mysql-workbench-community-8.0.30-1.el8.x86_64.rpm due to dependencies.

I am using RHEL 7.6


Please assist.



[[email protected] mysql-workbench]#

[[email protected] mysql-workbench]# yum install mysql-workbench-community-8.0.30-1.el8.x86_64.rpm

Loaded plugins: langpacks, ulninfo

Examining mysql-workbench-community-8.0.30-1.el8.x86_64.rpm: mysql-workbench-community-8.0.30-1.el8.x86_64

Marking mysql-workbench-community-8.0.30-1.el8.x86_64.rpm to be installed

Resolving Dependencies

--> Running transaction check

---> Package mysql-workbench-community.x86_64 0:8.0.30-1.el8 will be installed

--> Processing Dependency: libc.so.6(GLIBC_2.25)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.26)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.28)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_1b)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libm.so.6(GLIBC_2.27)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_0)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_1)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.11)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.22)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libOpenGL.so.0()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libcrypto.so.1.1()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libncurses.so.6()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpng16.so.16()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libproj.so.15()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpython3.8.so.1.0()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libssl.so.1.1()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libtinfo.so.6()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libzip.so.5()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Running transaction check

---> Package libglvnd-opengl.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed

---> Package mysql-workbench-community.x86_64 0:8.0.30-1.el8 will be installed

--> Processing Dependency: libc.so.6(GLIBC_2.25)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.26)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libc.so.6(GLIBC_2.28)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libm.so.6(GLIBC_2.27)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.11)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.22)(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libncurses.so.6()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpng16.so.16()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libproj.so.15()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libpython3.8.so.1.0()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libtinfo.so.6()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

--> Processing Dependency: libzip.so.5()(64bit) for package: mysql-workbench-community-8.0.30-1.el8.x86_64

---> Package openssl11-libs.x86_64 1:1.1.1k-4.el7 will be installed

--> Finished Dependency Resolution

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libc.so.6(GLIBC_2.25)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(CXXABI_1.3.11)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(CXXABI_1.3.8)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libm.so.6(GLIBC_2.27)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libc.so.6(GLIBC_2.27)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libpng16.so.16()(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libc.so.6(GLIBC_2.26)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libpng16.so.16(PNG16_0)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libpython3.8.so.1.0()(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libproj.so.15()(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(CXXABI_1.3.9)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libstdc++.so.6(GLIBCXX_3.4.22)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libtinfo.so.6()(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libc.so.6(GLIBC_2.28)(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libzip.so.5()(64bit)

Error: Package: mysql-workbench-community-8.0.30-1.el8.x86_64 (/mysql-workbench-community-8.0.30-1.el8.x86_64)

      Requires: libncurses.so.6()(64bit)

 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest

[[email protected] mysql-workbench]#

Tagged: