Forum Stats

  • 3,874,172 Users
  • 2,266,676 Discussions
  • 7,911,751 Comments

Discussions

After upgrading from 22.2.1 to 22.3.1 I see a lot of "Bad Message 400" errors

After upgrading from 22.2.1 to 22.3.1 I see a lot of "Bad Message 400 - reason: Ambiguous URI empty segment" errors that seem to be caused by an URL that contains multiple slashes like for example "http://127.0.0.1:7777/ords/lj_unittest//las_dlg_startup.go".

I don't know if this an intentional change or a bug but it is a major change breaking backwards compatibility, most likely will break a lot of code and does not seem to be documented.

The above url is accepted by ORDS 22.2.1 but fails in 22.3.1.

Tagged:

Answers