This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,901 Users
  • 2,269,775 Discussions
  • 7,916,823 Comments

Discussions

When configuring database creation for Oracle DB 21c-1.0 XE, I get errors about values.

The configure program is complaining about the SHARED_POOL_SIZE being too small (2560MB, wants it to be at least 3600). Also, about sga_target being too small. Where can I set these values so that the DB creation will succeed?


Thanks!

Answers

  • Billy Verreynne
    Billy Verreynne Software Engineer Cape TownMember Posts: 28,976 Red Diamond

    The PFILE used to start the database instance for the very first time. Default is (used to be) in directory $ORACLE_HOME/dbs.

  • asahide
    asahide Expert Technical Engineer Member Posts: 1,619 Gold Trophy

    Hi @User_7BQNJ ,

    With 21c, you can also use memory_target and sga_target instead of setting shared_pool_size individually.

    Regards,

  • User_7BQNJ
    User_7BQNJ Member Posts: 6 Green Ribbon

    I tried setting sga_target in the dbs/init.ora file which got rid of that specific message, but still get shared_pool_size error messages. I am pasting the output from the configure run, and also the contents of init.ora for review. Thanks.

    [[email protected] dbs]# /etc/init.d/oracle-xe-21c configure

    Specify a password to be used for database accounts. Oracle recommends that the password entered should be at least 8 characters in length, contain at least 1 uppercase character, 1 lower case character and 1 digit [0-9]. Note that the same password will be used for SYS, SYSTEM and PDBADMIN accounts:

    Confirm the password:

    Configuring Oracle Listener.

    Listener configuration succeeded.

    Configuring Oracle Database XE.

    [WARNING] [DBT-11205] Specified shared pool size does not meet the recommended minimum size requirement. This might cause database creation to fail.

      ACTION: Specify at least (2,592 MB) for shared pool size.

    Enter SYS user password:                                                                                          *************

    Enter SYSTEM user password:

    ************

    Enter PDBADMIN User Password:

    ***********

    [FATAL] [DBT-10011] Incorrect ownership/permissions detected for the file (/opt/oracle/product/21c/dbhomeXE/bin/oradism).

      CAUSE: Following nodes does not have required file ownership/permissions: Node :iceberg

    PRVG-11960 : Set user ID bit is not set for file "/opt/oracle/product/21c/dbhomeXE/bin/oradism" on node "iceberg".


      ACTION: Run the Oracle Home root script as the "root" user to fix the permissions.


    Database configuration failed. Check logs under '/opt/oracle/cfgtoollogs/dbca'.

    [[email protected] dbs]#

    init.ora contents:

    # Change '<ORACLE_BASE>' to point to the oracle base (the one you specify at

    # install time)


    db_name='ORCL'

    memory_target=4096

    processes = 150

    audit_file_dest='<ORACLE_BASE>/admin/orcl/adump'

    audit_trail ='db'

    db_block_size=8192

    db_domain=''

    db_recovery_file_dest='<ORACLE_BASE>/fast_recovery_area'

    db_recovery_file_dest_size=2G

    diagnostic_dest='<ORACLE_BASE>'

    dispatchers='(PROTOCOL=TCP) (SERVICE=ORCLXDB)'

    open_cursors=300 

    remote_login_passwordfile='EXCLUSIVE'

    undo_tablespace='UNDOTBS1'

    # You may want to ensure that control files are created on separate physical

    # devices

    control_files = (ora_control1, ora_control2)

    compatible ='11.2.0'

    sga_target=4096

    memory_target=4096