Forum Stats

  • 3,875,898 Users
  • 2,266,987 Discussions
  • 7,912,374 Comments

Discussions

Call Report from From Menu Oracle 10g

User_ZKDQZ
User_ZKDQZ Member Posts: 2 Green Ribbon
edited Nov 5, 2022 5:55AM in Forms

I am in the process to update my developer from Oracle 6i to Oracle 10g but I am facing the following issues 

After LOG-IN form when I go to the menu and click to run the report it doesn't work.

When I try to directly print to LAN Printer (especially large character mode/text report e.g 200 pages and above) report output close automatically . Moreover, compile speed of Oracle 10g reports is very slow rather than Oracle 6i. 

what should I do now?

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 7,493 Employee

    Why would you upgrade from 6i to 10g? Both have been desupported for over 15 years. Why not upgrade to a current version (e.g. 12.2.1.4)?

    When upgrading from v6 there are concept changes you need to consider. There are potentially code changes required to. I recommend reading this doc:

    https://docs.oracle.com/cd/B25016_08/doc/dl/web/B15572_01/B15572_01.pdf

    Also, the way you integrate with Reports from Forms when moving to the three tier architecture is different too. The Forms Migration Assistant (FMA) can help with the needed code changes or you can manually make the changes. The doc above will explain. In short, you must use RUN_REPORT_OBJECT and not RUN_PRODUCT in order to call Reports.

    Again, if you are moving to any newer versions I strongly recommend using a current version and not one that is so very old. The only exception would be if you are using it with E-Business Suite. If so, then using v10.1 is required.


    Michael Ferrante

    Senior Principal Product Manager

    Oracle

    Twitter: @OracleFormsPM

  • User_ZKDQZ
    User_ZKDQZ Member Posts: 2 Green Ribbon
    edited Nov 5, 2022 6:27AM

    Thanks for your answer Michael I forget to mention one point regarding point 2 that,this problem only happens with character mode/text report while printing .I am using Oracle EBS R12