Forum Stats

  • 3,874,176 Users
  • 2,266,677 Discussions
  • 7,911,754 Comments

Discussions

Connection string for Oracle ORDS docker container

Hello, I'm stuck trying to run the ORDS container over the Oracle-db container. I made the connection string txt file wich is mandatory, the docker engine can read it but this is the output:

Cannot connect to database please validate CONN_STRING has below shape: user/[email protected]:port/service_name

my connection string:

CONN_STRING=sys/#mypwd#@172.xx.0.xx:1521/ORCLCDB

My oracle-db container is up and running, can connect to it in SQL Developer (user and pwd are ok, service_name and port are ok).

Anything else I can try?

Both oracle-db container and ords container are set to run in the same docker network (so network ok) I tried with the container ip (the one 170.xx.0.xx like from) as hostname, no luck.

Tagged:

Answers

  • kdario
    kdario Member Posts: 3,543 Silver Crown
    edited Nov 5, 2022 7:28AM

    If you are really connecting as SYS user (as in your example), then you will probably need " as sysdba" clause in your connection string.

    To which ORDS docker image are you referring?

    If you have sqlplus / sqlcl in that image, you can open shell with something like:

    docker run -it --entrypoint sh YOUR_IMAGE
    

    and then try to connect to your database from it (i.e. sqlplus sys/#mypwd#@172.xx.0.xx:1521/ORCLCDB as sysdba) and see if you can get more details about error.

    Also note that your database is in docker container, so depending on DB and ORDS version, maybe you will have to disable OOB (out of band break) with something like this: ?oracle.net.disableOob=true appended to your connect string.

  • SorenStirner
    SorenStirner Member Posts: 3 Green Ribbon

    Thanks, now my connection string works

    CONN_STRING="sys as sysdba/#mypwd#@172.xx.0.xx:1521/ORCLCDB" (any other quotes combo didnt work).

    ORDS' container runs now and installs ORDS instance and APEX over the target oracle-db container.

    While the log file states:

    INFO : APEX has been installed.

    INFO : Configuring APEX.

    INFO : APEX_PUBLIC_USER has been configured as oracle.

    I cant find any trace of APEX in the dba_registry

    I can see the ords instance in http://myhostt:8181/ords/ but APEX login is not showing up (ORDS 404 instead with some errors I'm about to check out)

  • User_EUVRA
    User_EUVRA Member Posts: 1 Red Ribbon

    I am wondering if you have made any progress on this? I actually went into the ords cli and did the interactive interface installation. Doing this with the same values as my CONN_STRING and it actually installs without any issue and can connect to the database. At that point I run it in standalone mode but don't know what the url is to even access it, not sure if that's even possible to access the ports i used there. let me know if you have any more luck.