Forum Stats

  • 3,875,879 Users
  • 2,266,979 Discussions
  • 7,912,364 Comments

Discussions

WARNING The pool named: |default|lo| is invalid and will be ignored

user558632
user558632 Member Posts: 2 Green Ribbon

I am using ORDS 22.2.0 | APEX 22.1.0 with XE21c. All works wonderful.

But if I start ORDS before the DB, the following error occurs and ORDS never (waited several hours) connects to the database again:

WARNING   The pool named: |default|lo| is invalid and will be ignored: ORDS was unable to make a connection to the database. This can occur if the database is unavailable, the maximum number of sessions has been reached or the pool is not correctly configured. The connection pool named: |default|lo| had the following error(s): IO Error: The Network Adapter could not establish the connection (CONNECTION_ID=xxK1jRAIRRqeVnG06ZuFYQ==)


If I start the DB before ORDS, everything is fine. The connection is restored after restarting the DB.

Best Answer

Answers

  • thatJeffSmith-Oracle
    thatJeffSmith-Oracle Distinguished Product Manager Posts: 8,883 Employee
    Answer ✓

    Anytime I've tried this, after a few minutes, the pool is correctly established and ORDS carries on.

    If you can reliably reproduce this, please open a SR with My Oracle Support.

  • user558632
    user558632 Member Posts: 2 Green Ribbon

    The behavior is reproducible. I am using the Oracle Docker images (DB and ORDS).

    I thought there might be a setting for this behavior something like "db.invalidPoolTimeout=1m"

    I will wait for another version and then open an SR with support if necessary.


    Thanks for the quick reply!