Forum Stats

  • 3,875,427 Users
  • 2,266,915 Discussions
  • 7,912,205 Comments

Discussions

Script Output - Show full name column

User_JPI7N
User_JPI7N Member Posts: 4 Green Ribbon

Hello everyone, I work for two different companies and both have SQL Developer, but in one the names of the columns are shown complete and in the other they do not. I would like full names to be displayed in both, but I can't find where the settings are changed.

The one shown in the short names has Version 18.3.0.277. (in case the menus are different)

Example:

Greetings and thanks

Alberto

Best Answer

  • User_3ABCE
    User_3ABCE Member Posts: 212 Silver Badge
    Answer ✓
    SQL> set sqlformat ansiconsole
    SQL> select 'abc' long_identifier from dual;
    
    LONG_IDENTIFIER
    __________________
    abc
    
    SQL> set sqlformat default
    SQL Format Cleared
    SQL> select 'abc' long_identifier from dual;
    
    LON
    ---
    abc
    
    SQL> version
    Oracle SQLDeveloper Command-Line (SQLcl) version: 22.3.0.0 build: 22.3.0.270.1258
    
    thatJeffSmith-OracleUser_2DKLAUser_JPI7N

Answers

  • User_3ABCE
    User_3ABCE Member Posts: 212 Silver Badge
    Answer ✓
    SQL> set sqlformat ansiconsole
    SQL> select 'abc' long_identifier from dual;
    
    LONG_IDENTIFIER
    __________________
    abc
    
    SQL> set sqlformat default
    SQL Format Cleared
    SQL> select 'abc' long_identifier from dual;
    
    LON
    ---
    abc
    
    SQL> version
    Oracle SQLDeveloper Command-Line (SQLcl) version: 22.3.0.0 build: 22.3.0.270.1258
    
    thatJeffSmith-OracleUser_2DKLAUser_JPI7N
  • User_2DKLA
    User_2DKLA Member Posts: 63 Blue Ribbon

    In other words, this has little to do with SQL Developer, and all to do with SQL*Plus behaviour as regards printing column headers.

    Most likely the COLUMN settings are not the same in the two sessions—the NLS_DATE_FORMAT parameter is obviously different too.

    Use the COLUMN command to check (documentation here).

    Regards,

  • User_JPI7N
    User_JPI7N Member Posts: 4 Green Ribbon

    Thank you very much for the answer, it is just what I needed.

    Can the output be improved by displaying the hyphens below the field name?

    With the indicated commands, the header separation line is omitted


    Greetings and thanks

    Alberto