Forum Stats

  • 3,874,184 Users
  • 2,266,680 Discussions
  • 7,911,761 Comments

Discussions

Can't open Port( reverse ssh port forwarding)

User_5LEKR
User_5LEKR Member Posts: 1 Green Ribbon

Hello, i have a problem with not being able to open a port on my OCI

my setup: i have a server on my local network running PVE, couple lxc containers..

i host couple services now just for local use but i would like to open it for public/also learn self hosting as i am an IT student

the network is behind a NAT/CGNAT i don't know specificly and this isn't that much important as

i will use reverse ssh port forwarding

connections go like this:

  1. container game server (port 25565 udp and tcp too) (ip: 192.168.0.24)
  2. container has my ssh keys, manages port forwarding with the following command: ssh -nNTv -R 0.0.0.0:25565:192.168.0.24:25565 [email protected]<my OCI server ip> -i /this-is/where-is/my/ssh.key

i removed private stuff from it, if i run this it successfully forwards port back to 192.168.0.24

3.OCI intance: included photos

but when i check if the required ports are open i got this

so while on localhost its oppened the ports on the network controller side not

the software firewall config:

[[email protected] ~]$ sudo iptables --list

Chain INPUT (policy ACCEPT)

target   prot opt source        destination

Chain FORWARD (policy ACCEPT)

target   prot opt source        destination

Chain OUTPUT (policy ACCEPT)

target   prot opt source        destination

BareMetalInstanceServices all -- anywhere       169.254.0.0/16


this isn't all of it i haven't posted the "Chain BareMetalInstanceServices (1 references)" section, i might leak private information

i haven't worked with iptables before so if the problem is just a command here, i am realy sorry but i couldn't figure out


could someone please help how can i solve this?, so i can access the services i host locally

Tagged: