Forum Stats

  • 3,826,365 Users
  • 2,260,638 Discussions
  • 7,896,916 Comments

Discussions

Using JDeveloper on Vista - some tips

John Stegeman
John Stegeman Member Posts: 24,269 Blue Diamond
edited Jan 30, 2008 4:11AM in JDeveloper and ADF
Hello all,

Posting some of my experiences with JDev on Vista:

Be sure to get the latest 1.5 JDK from Sun and use this JDK to run JDeveloper. If you use the bundled JDK (1.5.0_5) - the Aero Glass UI will get disabled when you run JDeveloper. Not a show-stopper, but annoying.

If you use Microsoft's Intellipoint software (mouse drivers) - get rid of them. There's a bug in the JDK that makes the scroll wheel scroll the window DOWN when you turn the wheel UP - a major annoyance... Updating this... it seems now to happen whether I have Intellipoint installed or not. So, spinning the wheel makes the window scroll down, no matter which way you spin the wheel. Here's the bug post @ Sun: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6524352

The User Account Control (UAC) in Vista will prevent JDeveloper from associating files (.jws, .jpr, .jsp, .java) to JDeveloper. Furthermore, JDeveloper will ask you each and every time you start up if you want to associate. I fixed this by turning off UAC - but a safer alternative is to right-click jdeveloper.exe in windows explorer, and choose "run as administrator." You just need to do this once - answer "yes" or "no" as appropriate to associate the file types to JDeveloper.

I have always put "AddVMOption -Dswing.aatext=true" in my jdev.conf file to get nicely anti-aliased text in the JDeveloper menus and dialogs. Alas, this doesn't seem to work under Vista, and I haven't found a way around this yet.

Hope this helps.

John
Tagged:
«1

Comments

  • Frank Nimphius-Oracle
    Frank Nimphius-Oracle Member Posts: 29,689 Bronze Badge
    John,

    please let me know if there is anything that can be learly pointed to JDeveloper so I can file a bug. I don' have Vista installed and need to rely on someone who knows JDeveloper and experiences issues.

    thanks

    Frank
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    Hi Frank,

    Will do. However, from what I can see so far, it's all JVM issues, nothing specific to JDeveloper.

    Regards,

    John
  • Brian.Duff
    Brian.Duff Member Posts: 1,233
    For the anti aliased text... although it's not officially supported, running JDeveloper under Java 1.6 should give you AA text in a lot of places. If you use the Windows Look & Feel, it will also look at lot better on Vista with 1.6 compared to 1.5.

    There are still a few areas (most notably the main menus and text on dockable window tabs) where AA doesn't work even if you run under 1.6. As an anti aliased text fan, I have tried to hunt down and fix as many of these as possible for a future production release of jdeveloper... ;)

    Thanks,
    Brian
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    Hi Brian,

    Thanks for the tips. I dislike the Windows LAF, much preferring the Oracle (aka JGoodies) LAF.

    Some comments with JDK 6:

    The scroll wheel now works (somewhat) correctly. It scrolls up when spinning up and down when spinning down. However, I've got to spin it really fast. Perhaps it's time for a non-Microsoft mouse (the JDK bug seems to not happen with non-MS mice).

    It's nice to have the AA text back. Much easier on the eyes when using a high-res LCD.

    John
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    More notes,

    Just installed JDK 6u1
    c:\>java -version                                                   
    java version "1.6.0_01"                                             
    Java(TM) SE Runtime Environment (build 1.6.0_01-b06)                
    Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)
    Neither the scroll wheel nor the anti-aliased text issues seem to be resolved :(

    John
  • 275938
    275938 Member Posts: 3
    I get "io exception: The network adapter could not establish the connection" when I try to create a database connection in JDeveloper 10.1.3.2 to a locally installed 10g database on Vista. It's my first 30 mins working with Vista, so I'm not sure if it's a simple security fix. Thanks in advance to anyone who can point me in the right direction...
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    Hi PMurphy,

    "first 30 minutes in vista" - which version of the database did you install? Are you sure the database and listener are running? What connection information are you using? Can you TNSPING the listener from a command prompt?

    John
  • 275938
    275938 Member Posts: 3
    Thanks for the quick response. Here's the answers to your questions:
    Oracle Database 10g Enterprise Edition Release 10.2.0.3.0
    I logged into SQL*Plus and issued select * from v$version;
    The listener is up and my database registers itself after a few seconds of the listener being bounced in the services control panel...however, from the command prompt I can do lsnrctl status, but when I try to do lsnrctl reload, I get user not authorized. netca was user not authorized but I manually set permissions on the bin dir and that now works. I can't tnsping, it says no listener. When I try from the command prompt sqlplus [email protected] (to use the listener) it fails, but the windows version of SQL*Plus connects fine. I tried to see if I wasn't in the ORA_DBA group, but I have Vista Home Premium and there isn't a way to set groups that I have found yet. Worst case, I'll just run JDeveloper on the windows box and connect to a copy of my practice database running on a different (linux) computer.

    I'm really not liking the Vista permissions/security setup so far...Any advice? Thanks!
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    edited Jun 7, 2007 3:24AM
    Hi Pmurphy,

    Ditto on the permissions thing in Vista - quite annoying.

    Did you install the Vista version of the database? I have disabled UAC (user access control - google the web for instructions how; it's not hard). Can you "tnsping localhost:1521"

    Doesn't sound like a JDev problem at this point...

    John
  • 275938
    275938 Member Posts: 3
    Thanks! I got it working...I had to disable UAC via the registry key and then I changed "localhost" to the actual IP in the JDBC connection and it went right through. I looked at the hosts file and localhost is in there, but it didn't like it for some reason. It likes the IP address, though. Thanks again...
This discussion has been closed.