Forum Stats

  • 3,839,011 Users
  • 2,262,438 Discussions
  • 7,900,835 Comments

Discussions

Connection Problems

446408
446408 Member Posts: 3
edited Jul 6, 2007 7:44PM in Enterprise Pack for Eclipse
I wasn't able to connect to the 9i database via the plugin.

Could not connect to ma_tst.
Error creating Oracle Database Connection Factory connection to ma_tst. (Error: Invalid thread access)
Error creating SQL Model Connection connection to ma_tst. (Error: Invalid thread access)

Comments

  • 419511
    419511 Member Posts: 97
    Please provide more details on database version, os and any messages that is reported in Eclipse which is accessible using Help->About Eclipse->Configuration Details->View Error Log.
  • 10187
    10187 Member Posts: 1
    Experiencing similar issues with Eclipse 3.3 (Europa), DT 1.5 and the current Oracle dbtools version 1.0.0.464.

    !SUBENTRY 1 org.eclipse.datatools.connectivity 4 -1 2007-07-06 15:36:26.076
    !MESSAGE Error creating Oracle Database Connection Factory connection to test-db01. (Error: Io exception: The Network Adapter could not establish the connection)
    !STACK 0
    java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
    at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
    at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:146)
    at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:255)
    at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:387)
    at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:414)
    at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:165)
    at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:35)
    at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:801)
    at oracle.dbtools.dtp.connectivity.db.OracleJDBCConnection.createConn(OracleJDBCConnection.java:258)
    at oracle.dbtools.dtp.connectivity.db.OracleJDBCConnection.createConnection(OracleJDBCConnection.java:191)
    at org.eclipse.datatools.connectivity.DriverConnectionBase.internalCreateConnection(DriverConnectionBase.java:104)
    at org.eclipse.datatools.connectivity.DriverConnectionBase.open(DriverConnectionBase.java:53)
    at oracle.dbtools.dtp.connectivity.db.OracleJDBCConnectionFactory.createConnection(OracleJDBCConnectionFactory.java:42)
    at org.eclipse.datatools.connectivity.internal.ConnectionFactoryProvider.createConnection(ConnectionFactoryProvider.java:77)
    at org.eclipse.datatools.connectivity.internal.ConnectionProfile.createConnection(ConnectionProfile.java:354)
    at org.eclipse.datatools.connectivity.internal.ManagedConnection.createConnection(ManagedConnection.java:166)
    at org.eclipse.datatools.connectivity.internal.CreateConnectionJob.run(CreateConnectionJob.java:56)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
  • 419511
    419511 Member Posts: 97
    edited Jul 6, 2007 7:44PM
    looks like a network connectivity issue to me.

    troubleshoot by

    1. if you have oracle installed try, $ORACLE_HOME/bin/tnsping test-db01.
    2. If no oracle, try telnet dbhost 1521 assuming your TNS listener is running at port 1521. If this telnet connection establishes then we have a problem on the eclipse end if not a firewall could be blocking the access.

    btw, with listener at port 1521, your connection url will look like jdbc:oracle:thin:@dbhost:1521:test-db01
This discussion has been closed.