Forum Stats

  • 3,758,238 Users
  • 2,251,358 Discussions
  • 7,870,124 Comments

Discussions

ORA-01031: insufficient privileges While trying / as sysdba

2

Comments

  • 534640
    534640 Member Posts: 236
    Friends,
    Since we are on linux so the password file is created at default /dbs location.

    As I had mentioned above we have tried recreating the password file again and again but unable to login. We have tried all possible cases like password file,sqlnet.ora file changes,relink oracle libraries, rechecking of os user and groups etc.

    Any other idea folks..............
  • 628871
    628871 Member Posts: 93
    edited Apr 9, 2008 6:54AM
    Hi khalid,

    I faced the same problem.

    just give a try with the password file.

    be specific with file name.

    orapwd file=orapwPRODT password=mypassword entries=5.

    make sure your file name is orapw(dbname).. hope it will work. try it and let me know if am wrong.

    Message was edited by:
    user625868
  • Sabdar Syed
    Sabdar Syed Member Posts: 1,881
    edited Apr 9, 2008 7:10AM
    >> I have recreated the password file:
    orapwd file=orapwdPRODT password=mypassword


    Yes, as already told.

    Create password file again with as follow, because in your command there was a d in file=orapwdPRODT

    orapwd file=orapwPRODT password=mypassword

    Regards,
    Sabdar Syed.

    As I just tested on my test server,
    With orapwd<SID> file, then I'm getting error.

    ORA-01990: error opening password file '/oracle/ora92/dbs/orapw'
    ORA-27037: unable to obtain file status

    When I try with, orapw<SID>.
    It's connecting fine.

    Message was edited by:
    Sabdar Syed
  • 534640
    534640 Member Posts: 236
    edited Apr 9, 2008 7:32AM
    Syed,
    Sorry for the typing mistake its orapwSID file
    -----------------------------------------------------------------------
    [[email protected] dbs]$ ls -ltr orapw*
    -rw-r----- 1 oracle dba 1536 Apr 9 10:56 orapwPRODT

    Password file is correct I think because we can connect with sys user when we supply the password.
    I have tried one more thing that (after login as sysdba after supplying passwrd) I changed the password of sys and then disconnected and relogin with new password and it was working. This shows that we have valid password files.
  • 537688
    537688 Member Posts: 12
    Is there any solution given to Sabdar's problem ? ?

    I am facing similar issue as Sabdar, and tried all the possible ways, but conn / as sysdba still gives ORA-01031
  • 730296
    730296 Member Posts: 1
    Try to see this line, SQLNET.AUTHENTICATION_SERVICES = (NTS), in sqlnet.ora file if exists. If yes, comment that and try to connect using / as sysdba. Post here if it´s work.
    user10131436
  • I was in the same boat and commenting out the SQLNET.AUTHENTICATION_SERVICES= (NTS) line in the sqlnet.ora file allow me to log into sqlplus with

    SQL> connect / as sysdba
    Connected.
    SQL>

    Matt - [email protected]
  • 745928
    745928 Member Posts: 6
    Hello,

    export ORACLE_SID=duprdb

    sqlplus "/ as sysdba"

    alter system register;

    i am sure you will be able now to conn as sqlplus sys/***@duprdb as sysdba


    Please respond if successful even if it is not, i would try to help, I already simulated it and was successful with it !!

    Lalit Verma
    http://sites.google.com/site/racinsights1
    user4879448
  • 745928
    745928 Member Posts: 6
    Hello,

    This is for Windows, but in unix you do not have NTS authentication

    Lalit Verma
    http://sites.google.com/site/racinsights1
  • KeshavM
    KeshavM Member Posts: 178
    could you check by which user oracle installations are done?
This discussion has been closed.