Forum Stats

  • 3,758,242 Users
  • 2,251,358 Discussions
  • 7,870,124 Comments

Discussions

ORA-01031: insufficient privileges While trying / as sysdba

13»

Comments

  • Anil Malkai
    Anil Malkai Member Posts: 603
    if you are the owner of the oracle software and you are in DBA group then

    try creating your password file this way.it should work.

    orapwd file=orapw password=mypassword

    dont give SID or any extention to your password file.

    Anil Malkai
    3230652
  • marcusafs
    marcusafs Member Posts: 294
    edited Feb 23, 2010 10:36AM
    Fkhalid is right in telling you to include the entries=5 option in the create password file.

    ENTRIES
    This parameter specifies the number of entries that you require the password file to accept. This number corresponds to the number of distinct users allowed to connect to the database as SYSDBA or SYSOPER. The actual number of allowable entries can be higher than the number of users because the ORAPWD utility continues to assign password entries until an operating system block is filled. For example, if your operating system block size is 512 bytes, it holds four password entries. The number of password entries allocated is always multiple of four.

    Entries can be reused as users are added to and removed from the password file. {color:red}If you intend to specify REMOTE_LOGON_PASSWORDFILE=EXCLUSIVE, and to allow the granting of SYSDBA and SYSOPER privileges to users, this parameter is required.{color}

    Edited by: Marcus AFS on Feb 23, 2010 9:36 AM
  • J_K
    J_K Member Posts: 77
    syed

    you are genius.

    i had same problem.

    i tried everything but didnt get through

    select * from v$pwfile_users. didnt show me any rows

    then i created password file according your suggested way.

    and it works

    thanks lot dear
  • 875642
    875642 Member Posts: 1
    edited Jul 14, 2011 3:41PM
    If password file is ok and the group is correct for the oracle account, you might also want to check file $ORACLE_HOME/rdbms/lib/config.c
    It should contain the oracle database group.
    Running ./runInstaller on the copied oracle home can update this file and possibly remove this entry.
    If so, edit config.c, add the oracle database group, eg oiinstall , and run make on oracle or relink all. Then sqlplus / as sysdba should work.

    Edited by: George Rose on Jul 14, 2011 12:41 PM
    User_96XBT
  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond

    look at start date of thread & date of last response before resurrecting ancient zombie thread which should remain dead & undisturbed.

    Alvaro
This discussion has been closed.