Forum Stats

  • 3,781,103 Users
  • 2,254,481 Discussions
  • 7,879,567 Comments

Discussions

APEX 3.1 Install Error (apxldimg.sql errors out) in Oracle 10g

guruparan
guruparan Member Posts: 150
edited Oct 10, 2008 11:24AM in APEX Discussions
Hi All

I am installing apex 3.1 on Oracle 10g XE. I have completed the first step [as mentioned|http://www.oracle.com/technology/products/database/application_express/html/3.1_and_xe.html] . For the second step, I need to run apxldimg.sql. When I try executing this, I got the following error.

The folder where I un-zipped the install files is 'C:\apex\apex_3.1

I tried searching for solution through the forum. I couldn't find it for the past three hours. Could some one please help me out with. Thanks in advance.
SQL> @apxldimg.sql C:\Apex\apex_3.1

PL/SQL procedure successfully completed.


Directory created.

declare
*
ERROR at line 1:
ORA-22288: file or LOB operation FILEOPEN failed
The system cannot find the path specified.
ORA-06512: at "SYS.DBMS_LOB", line 523
ORA-06512: at "SYS.XMLTYPE", line 287
ORA-06512: at line 15



PL/SQL procedure successfully completed.


Commit complete.

timing for: Load Images
Elapsed: 00:00:00.01

Directory dropped.
Tagged:

Answers

  • guruparan
    guruparan Member Posts: 150
    Ok. Got it myself... The image loader apxldimg.sql was configured as below
    create directory APEX_IMAGES as '&1/apex/images';
    And there is not such folder as /apex/images.

    I edited the folder structure such that it is as follows
    create directory APEX_IMAGES as '&1/images';
    That solved the problem. Thanks guys!
This discussion has been closed.