Forum Stats

  • 3,839,951 Users
  • 2,262,553 Discussions
  • 7,901,102 Comments

Discussions

Unable to Start the OC4J Server from the JDeveloper 9.0.3

harikumarmpl
harikumarmpl Member Posts: 56
edited Oct 13, 2008 8:33AM in JDeveloper and ADF
Hi to all,

I am trying to start the OC4J Server from the JDeveloper but the error i got is this.
For this the configurations are username: admin password : welcome

I cannot able to start the server .


javax.naming.NamingException: IO Error: Connection refused: connect

javax.naming.NamingEnumeration com.evermind.server.rmi.RMIContext.list(java.lang.String, boolean, com.evermind.net.AddressContainer)

RMIContext.java:347

javax.naming.NamingEnumeration com.evermind.server.rmi.RMIContext.list(java.lang.String)

RMIContext.java:291

javax.naming.NamingEnumeration javax.naming.InitialContext.list(java.lang.String)

InitialContext.java:390

void oracle.jdevimpl.cm.dt.browser.jndi.JNDIBrowser._testContext(javax.naming.Context)

JNDIBrowser.java:175

void oracle.jdevimpl.cm.dt.browser.jndi.JNDIBrowser.openConnectionBrowser(oracle.jdeveloper.cm.dt.ConnectionBrowsable)

JNDIBrowser.java:77

java.lang.Object oracle.jdeveloper.cm.dt.ConnectionNode$NodeOpen.doWork()

ConnectionNode.java:202

void oracle.jdeveloper.cm.dt.ProgressRunnable.run()

ProgressRunnable.java:193

void oracle.ide.dialogs.ProgressBar.run()

ProgressBar.java:527

void java.lang.Thread.run()

Thread.java:484




And also one more problem is there

I have a servlet for example:
HelloServlet

if i run the servlet from the JDeveloper
it will open a browser and it will stay in the same URL
D:\jdev\jdev\mywork\Test\Example\WebAppRunner.html which contains Loading.......
and it is not opening the servlet
http://142.102.27.30:8988/Test-Example-context-root/HelloServlet

and in the JDeveloper the Logs are:


[Starting OC4J using the following ports: HTTP=8988, RMI=23891, JMS=9227.]
D:\jdev\jdk\bin\javaw.exe -ojvm -classpath D:\jdev\j2ee\home\oc4j.jar -Xverify:none com.evermind.server.OC4JServer -config D:\jdev\jdev\system9.0.3.1.1107\oc4j-config\server.xml
[waiting for the server to complete its initialization...]
Embedded OC4J startup time: 1015 ms.

Target URL -- http://142.102.27.30:8988/Test-Example-context-root/HelloServlet
Oracle9iAS (9.0.3.0.0) Containers for J2EE initialized

Embedded OC4J startup time: 0 ms.

Can any body help on this please

Thank you in advance
Hari
Tagged:

Answers

  • Jan Vervecken
    Jan Vervecken Member Posts: 2,842
    hi Hari

    You write about "JDeveloper 9.0.3", and maybe you have a good reason for that, but just to be sure, check out this recent blog post about JDeveloper 10.1.3.4.0 and JDeveloper 11.1.1.0.0 which are the current production versions.

    http://blogs.oracle.com/reynolds/2008/10/which_jdev_is_right_for_me.html

    success
    Jan Vervecken
This discussion has been closed.