Forum Stats

  • 3,839,636 Users
  • 2,262,517 Discussions


PL/SQL numeric or value error

Nicola Farina
Nicola Farina Member Posts: 44
edited Oct 15, 2008 2:59AM in ODP.NET
Hello all,

I have this error at the customer's site, after deploying my application.
The stored procedure called is something like:

OracleCommand cmd = new OracleCommand(
"begin \n" +
ApplicationSchema + ".IAccessOra.GetFormScript(:IdForm, :DdScript, :Azione, 1); \n " +
"end;", MainSession);
cmd.CommandType = CommandType.Text;
cmd.BindByName = true;
cmd.Parameters.Add("IdForm", OracleDbType.Decimal, IdForm, ParameterDirection.Input);
cmd.Parameters.Add("DdScript", OracleDbType.Clob, 32000, DBNull.Value, ParameterDirection.Output);
cmd.Parameters.Add("Azione", OracleDbType.Varchar2, 10, GlobalMembers.cScriptEventId[(int)Evento], ParameterDirection.Input);

It seems the situation of bug 4015165, but the error is systematic, not intermittent.
But when I tried to build a test case I failed. The same function which fails in the main project, works or has intermittent errors when set aside in another project.
In office everything works.


database 9206 client win 2003 R2 standard sp 2 (virtual with vmware)

database 9207 client and 11 win 2003 R2 standard sp 2 (virtual with vmware)

In office I have never seen this error, and I have 9207, so
I asked the customer to patch his database to 9207 or 9208.

Is this advice reasonable in your opinion ?

Btw I tried to enable trace at the customer site but it doesn't generate the trace file. Could it depend on the fact that the server
is virtual ?

Thanks for any idea/advice/tip


  • 24208
    24208 Member Posts: 1,295
    Hi Nicola,

    I think that asking your customer to apply a later patchset is a reasonable request. There is a one-off patch available for for this particular issue as well (assuming this is the real cause).

    I have not had issues with trace not working in a virtual machine.

    Not sure that is much help, but maybe...


  • Hi Mark

    Thanks for answering.
    About the tracefile problem ...
    Actually even my test machine in office is a virtual one, so certainly it is not the problem.
    I simply edited the TraceLevel key in the registry to enable the trace (I putted the value 9).
    I have done the same thing on my test machine and on the client machine.
    But on the latter the trace file doesn't get generated while on the first it works perfectly ....
    Have you ever seen a problem like this ?

  • 24208
    24208 Member Posts: 1,295
    Hi Nicola,

    Sorry, I have not seen that problem before. I assume the TraceFileName is valid, etc...

  • Hi,

    I've seen tracing not work on older versions of ODP when the OraOps10.dll was moved outside of the Oracle home\bin. Are all your oraops.dll's in the right place?

    Hope it helps,
  • Hi Greg

    I haven't moved any file but I'll check this file, thanks.

    Yes, parameters in registry are all ok. Filename is the default (something like c:\odpxx.trc). For test I tried specify another path but with
    no success. Usually setting the TraceLevel is enough to enable the trace (or at least I've always done this way)..
    Thanks anyway
This discussion has been closed.