Forum Stats

  • 3,758,598 Users
  • 2,251,417 Discussions
  • 7,870,259 Comments

Discussions

Error while connecting to workflow builder after installation...first time!

650593
650593 Member Posts: 113
edited Jan 2, 2009 4:37AM in Database Installation
Hi,

I have installed Oracle Workflow Builder 2.6.3 recently on my system and after installation, when I am trying to connect the workflow builder (using database username/password of that particular instance), it is throwing me the following error:

220: Unable to set NLS_LANGUAGE.
210: Oracle Error: ORA-01403: no data found
. SQL text: SELECT NLS_LANGUAGE FROM WF_LANGUAGES WHERE :l IN (NLS_LANGUAGE, CODE)

In the previous threads when I searched for the same issue, I found that if
select value from v$nls_parameters
where parameter='NLS_CHARACTERSET';
returns the value other then WE8ISO8859P1 then that is what I should change my NLS_LANG entry for the builder - i.e. AMERICAN_AMERICA.<character set>.

But I am not getting where should I change NLS_LANG, it is located where...some file? I am new to Workflow.
Please help me. I tried a lot. Any type of help will be highly appreciated.

Thanks,
Sumir
Subhashini Shanmugam

Best Answer

  • OrionNet
    OrionNet Member Posts: 4,542
    edited Jan 2, 2009 3:28AM Accepted Answer
    Sumir,

    Is it windows server? You can try this
    Set NLS_LANG as an operating system environment variable:
    
    1. Select Start - Control Panel - System
    
    2. Select Environment 
    
    3. Set NLS_LANG parameter to AMERICAN_AMERICA.UTF8.
    Or try this
    1. define NLS_LANG Environment Variable on your PC, following below navigation :
    
    
    For Windows 
    Start / Settings / Control Panel / System / Advanced / Environment Variables
    Define new "System Variable" NLS_LANG and assign it the value AMERICAN_AMERICA.WE8MSWIN1252
    
    
    Save
    
    2. Bounce the PC
    
    3. Try again database connection from Workflow Builder
    Regards

    Edited by: OrionNet on Jan 2, 2009 3:28 AM

Answers

  • OrionNet
    OrionNet Member Posts: 4,542
    edited Jan 2, 2009 3:28AM Accepted Answer
    Sumir,

    Is it windows server? You can try this
    Set NLS_LANG as an operating system environment variable:
    
    1. Select Start - Control Panel - System
    
    2. Select Environment 
    
    3. Set NLS_LANG parameter to AMERICAN_AMERICA.UTF8.
    Or try this
    1. define NLS_LANG Environment Variable on your PC, following below navigation :
    
    
    For Windows 
    Start / Settings / Control Panel / System / Advanced / Environment Variables
    Define new "System Variable" NLS_LANG and assign it the value AMERICAN_AMERICA.WE8MSWIN1252
    
    
    Save
    
    2. Bounce the PC
    
    3. Try again database connection from Workflow Builder
    Regards

    Edited by: OrionNet on Jan 2, 2009 3:28 AM
  • 650593
    650593 Member Posts: 113
    Hi OrionNet,

    Thanks a lot! It worked! Hope it should not affect any other things in my system.

    Regards,
    Sumir
This discussion has been closed.