Forum Stats

  • 3,853,719 Users
  • 2,264,259 Discussions
  • 7,905,435 Comments

Discussions

Troubles editing tables with partitions

677978
677978 Member Posts: 7
edited Jul 17, 2009 5:36PM in SQL Developer
I'm running SQL Developer 1.5.3 against Oracle 10/11 databases and SQL Developer has trouble with my partitioned tables. Both the schema owner and sys users experience the same problems.

The first time I try to edit a table, I get an "Error Loading Objects" dialog with a NullPointException message. If I immediately turn around and try to edit the table again, I get the Edit Table dialog. That's annoying but there's at least a work-around.

Next, if I select the Indexes pane, I can view the first index but selecting another one results in an "Index Error on <table>" error dialog. The message is "There are no table partitions on which to define local index partitions". At this point, selecting any of the other panes (Columns, Primary Key, etc.) results in the same dialog. While the main Partitions tab shows my partitions, I cannot see them in the Edit Table dialog. In fact, the Partition Definitions and Subpartition Templates panes are blank.

Does anyone else see this behavior? Version 1.5.1 behaved the same way so it's not new.

Of course I've figured out how to do everything I need through SQL but it would be handy if I could just use the tool.

Thank you.

Answers

  • -K-
    -K- Member Posts: 6,171
    I don't have any problem with this.
    Can you post the full error stack? If you don't get it in the error dialog, you can get the stack from the console window when you run from +\sqldeveloper\bin\sqldeveloper.exe+.

    K.
  • 677978
    677978 Member Posts: 7
    The stack trace is shown in neither the dialog nor the console. For the Linux version, I tried to find a log file under ~/.sqldeveloper but there doesn't appear to be one. In the Preferences, there is a panel in Environment -> Log which would lead me to believe that I can enable some sort of logging. I set the log directory to the default mywork directory but no files are generated.

    Any ideas?
  • Jim Smith
    Jim Smith Member Posts: 2,877 Silver Trophy
    On linux, if you run sqldeveloper from a terminal window you should see the console messages in the terminal window.
  • 677978
    677978 Member Posts: 7
    Most of my tables are generated from a script so this morning I decided to just create a very basic partitioned table. It contained a NUMBER primary key and a TIMESTAMP(6) column to use with partitioning. That table worked just fine in SQL Developer.

    At that point I tried to figure out what is different about my tables and I finally found the difference... Oracle Spatial. If I add an MDSYS.SDO_GEOMETRY column to my partitioned table, SQL Developer starts having issues.

    I also have the GeoRaptor plugin installed so I had to wonder if it was interfering with SQL Developer. I couldn't find an option to uninstall an extension so I went into the sqldeveloper/extensions directory and removed GeoRaptorLibs and org.GeoRaptor.jar. GeoRaptor doesn't appear to be installed in SQL Developer anymore but I still see the same behavior.

    It appears that there is an issue in SQL Developer with Oracle Spatial and partitioning. Can someone confirm this?
  • 677978
    677978 Member Posts: 7
    Nope. I tried it in both Windows and Linux and neither of them produce output during my errors. Is there a command-line option to enable logging?
  • user148120
    user148120 Member Posts: 805
    We get the "Index Error on <table>" for different reasons. Same results, cant use the gui.
    Not paritioned or anything fancy.

    Index XXX_PK is defined identically to constraint PK_XXX.
    OK



    Yes that's all good but don't stop me from editing other stuff.
    Is there an option to turn this error checking off?
  • 677978
    677978 Member Posts: 7
    I've tried running version 1.5.5 and the problem persists. At this point I am not using the GeoRaptor plugin so this looks like a genuine bug in SQL Developer.

    To summarize, the problem that I am seeing is an inability to use SQL Developer to edit tables that contain a spatial column and are partitioned. Editing one of these tables causes a popup saying NullPointerException. Removing the spatial column causes the Edit Table dialog to work properly.
This discussion has been closed.