Forum Stats

  • 3,872,071 Users
  • 2,266,376 Discussions
  • 7,911,043 Comments

Discussions

Migration of an Access DB

582007
582007 Member Posts: 127
edited Jan 12, 2009 12:49PM in APEX Discussions
Hi all.

I tired to migrate an access 97 DB with some tables, a form... and I get that all the objects were invalid. So I tried to migrate a DB with
only one table, I followed all the steps of the appex migration guide. But I get that the table is invalid too. Is there some incompatibility
with the access version?

Appex is installed in an Oracle 9.2.0.8.

Thanks in advance.
«1

Answers

  • 654241
    654241 Member Posts: 139
    edited Jan 9, 2009 7:43AM
    Hello,

    Did you use the right version of the Access exporter? The exporter is access version dependant...
    Exporter for Microsoft Access 97 omwb97.zip 10.2.0.2.5
    Which version of Apex do you use?

    Cheers,

    Arnaud

    Edited by: Arnaud Reper on Jan 9, 2009 1:42 PM
  • 582007
    582007 Member Posts: 127
    Yes, omwb97.zip version 10.2.0.2.5
    Appex: 3.1.2
  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,406 Employee
    Hi David,

    Your objects may appear as invalid in your Oracle Application Express Migration Project for a number of reasons:
    <ul><li>the database objects were not successfully migrated by [Oracle SQL Developer Migration Workbench|http://www.oracle.com/technology/tech/migration//workbench/index_sqldev_omwb.html|Oracle SQL Developer Migration Workbench] to Oracle</li>
    <li>the schema associated with your Migration Project does not contain the newly migrated database objects, generated by Oracle SQL Developer Migration Workbench</li>
    <li>the migrated Oracle table does not have a Primary Key</li>
    </ul>
    If you believe that your issue doesn't fall into one of the categories listed above, then can you please outline the steps you carried out as part of your migration process, from your use of Oracle SQL Developer Migration Workbench to migrate the Access database to Oracle and then the steps you carried out in generating your Migration Project in Oracle Application Express? This would greatly assist in trying to identify the cause of your problem. Also, please note that there should be no issue with the version of MS Access you are migrating from - we support MS Access '97 migrations.

    Regards,
    Hilary
  • 582007
    582007 Member Posts: 127
    Is there some log where I can see why the objects are invalid after the migration to apex? I supouse I made some mistake in the proces.
  • Hi,

    1.
    Be aware there is a separate forum for access to Apex.
    2.
    A very usefull paper can be found here
    http://www.oracle.com/technology/products/database/application_express/migrations/mig_faq.html#03

    Kind regards,
    Iloon
  • 582007
    582007 Member Posts: 127
    I don't know what's wrong. I followed again the steps of the paper you suggested.

    I run the exporter for Microsoft Access tool and generate the XML and SQL files.
    I migrate the Access DB to Oracle DB where apex is installed using the XML file.
    I executed the DDL statemet generated by the sql dev to create the schema in the DB and the schema is created with the empty table.
    I create a new workspace reusing the schema generated before.
    I create the project for the migrations using the .sql generated but the migration still returns that the table is invalid.

    I opened the .sql, the WWV_MIG_ACC_LOAD.INS_WWV_MIG_ACCESS call , in the p_dbpathname uses 'C:\Documents and Settings\dsoriano\Escritorio\apexOracle\AccesPrueba.mdb',

    Do I have to create a conection to the Oracle DB via ODBC or something? I'm lost.
  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,406 Employee
    Hi David,

    The SQL script generated by the Exporter tool contains the MS Access application information, and is used for reference purposes only. Once you logged into your Oracle APEX instance, you are not required to create any additional connections. If your database objects have been successfully migrated, and the tables have Primary Keys, then unsure why they would still appear as invalid. Would it be possible for me to obtain a copy of your Exporter-generated XML and SQL files, in order to investigate this issue further? If possible, then please post an email address that I can contact you directly at, or just update your OTN forum profile with an email address.

    Regards,
    Hilary
  • 582007
    582007 Member Posts: 127
    Profile updated.

    The table has primary key in the .mdb. But in the script generated in sql dev doesn't appear.

    Thanks
  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,406 Employee
    edited Jan 12, 2009 7:42AM
    Hi David,

    So does your newly migrated Oracle table NOT have a Primary Key? If this is the case, then that would explain why the table is appearing as invalid in your migration project. You would need to create a Primary Key on the table, either via SQL Workshop or SQL Developer. Then review the objects in your migration project, and the table should now appear as valid.

    Regards,
    Hilary

    Edited by: hfarrell on Jan 12, 2009 12:38 PM
  • 582007
    582007 Member Posts: 127
    edited Jan 12, 2009 11:29AM
    That's it.

    Now is migrated. A log of the creation would be useful.

    Thanks a lot.

    Edited by: Valencia on 12-ene-2009 17:29
This discussion has been closed.