Forum Stats

  • 3,826,799 Users
  • 2,260,708 Discussions
  • 7,897,074 Comments

Discussions

SQLNET.ALLOWED_LOGON_VERSION

user20050
user20050 Member Posts: 44
edited Jan 28, 2010 4:09PM in General Database Discussions
If i set this parameter in the sqlnet.ora file, do i need to set a corresponding value via jdbc similar to "oracle.net..." similar to encryption?

sqlnet.ora entry
SQLNET.ALLOWED_LOGON_VERSION = 10

I'm running 10gR1 on Linux and trying to connect via jdbc (ojdbc14.jar) and its failing with

ORA-28040: No matching authentication protocol


If SQLNET.ALLOWED_LOGON_VERSION is set only in the sqlnet.ora with no property in jdbc i get

ORA-28040: No matching authentication protocol


If SQLNET.ALLOWED_LOGON_VERSION is set in sqlnet.ora and in the jdbc prop (oracle.net.allowed_logon_version=10) file I still get

ORA-28040: No matching authentication protocol

It says to set it on both the client and server -- how do you set it on the client?


Any guidance is appreciated

Thanks,

Answers

  • oradba
    oradba Member Posts: 10,214
    You are hitting bug 6051243,details on metalink:

    Error "ORA-28040: No matching authentication protocol" When Using SQLNET.ALLOWED_LOGON_VERSION Doc ID: 755605.1

    Werner
    oradba
  • Anand...
    Anand... Member Posts: 3,590
    Hi..

    From metalink:-

    >
    Error: ORA-28040 (ORA-28040)
    Text: No matching authentication protocol
    ---------------------------------------------------------------------------
    Cause: No acceptible authentication protocol for both client and server
    Action: Administrator should set SQLNET_ALLOWED_LOGON_VERSION parameter
    on both client and servers to values that matches the minimum
    version supported in the system.
    >


    HTH
    Anand
  • Ebar,

    This is a reported bug in 10.1.0.2, which proceeds with authentication failure and would require you to do the following:

    *01 -* Set the DB_ALLOWED_LOGON_VERSION parameter in init.ora/SIDinita.ora as follows:

    db_allowed_logon_version=10

    *02 -* Specify matching authentication protocols for the client/database. To achieve this, make the following adjustments in SQLNET.ora file:

    SQLNET_ALLOWED_LOGON_VERSIONS=(10,9,8,7)

    Note: 10,9,8,are 7 the only values allowed. Details can be found in Oracle Net Services Guide at http://www.cis.unisa.edu.au/oracle/network.101/b10776/sqlnet.htm

    Hope this helps.

    Regards,
    Naveed.
    Naveed Yameen Khakoo
  • user20050
    user20050 Member Posts: 44
    Thanks everyone.
  • EdStevens
    EdStevens Member Posts: 28,778 Gold Crown
    Anand... wrote:
    Hi..

    From metalink:-

    >
    Error: ORA-28040 (ORA-28040)
    Text: No matching authentication protocol
    ---------------------------------------------------------------------------
    Cause: No acceptible authentication protocol for both client and server
    Action: Administrator should set SQLNET_ALLOWED_LOGON_VERSION parameter
    on both client and servers to values that matches the minimum
    version supported in the system.
    >


    HTH
    Anand
    Better check your user agreement with MetaLink. You are not supposed to expose Metalink content to non-authorized users.

    Though in this particular case, the exposed content is available from other sources.
This discussion has been closed.