Forum Stats

  • 3,815,456 Users
  • 2,259,028 Discussions
  • 7,893,107 Comments

Discussions

Need Help Upgrading OATS Ver:8.01.0249 to OATS Ver:8.50.0260

413404
413404 Member Posts: 2
edited Apr 9, 2009 4:02PM in QA/Testing
I'm currently having troubles upgrading Oracle Application Testing Suite from version 8.01.0249 to version 8.50.0260. The database for OATS is SQL Server 2000. I've unistalled the application ver 8.01.0249 completely. Followed by installing the applications ver 8.50.0260. I've configured ver 8.50.0260 to point to the existing SQL Server 2000 OATS database so that it can upgrade it to the latest version. When I run the OATS test suite administrator login to upgrade the SQL database, I get the following error message "The e-Manager Enterprise database could not be updated. Please make sure that the user has Administrator rights for the database and that the password entered is correct." The old application version 8.01.0249 connects fine with those credentials. Please see logs info below.


The JBossService logs show the following results:

INFO | jvm 1 | 14:30:06,830 INFO [EmeHttpSessionListener] New session: id=724B3D04FFFDC2BBC996FFDD94C17A62 created=Tue Apr 07 14:30:06 WST 2009
INFO | jvm 1 | 14:30:06,830 INFO [EmeHttpSessionListener] Current session time out:=1800
INFO | jvm 1 | 14:30:06,830 INFO [[eme]] action: --Action=/upgradeDatabase.do: LogonAction._upgradeDatabase()
INFO | jvm 1 | 14:30:06,830 INFO [[eme]] action: MethodLogonUser--
INFO | jvm 1 | 14:30:06,877 INFO [[eme]] action: actionForward is null:
INFO | jvm 1 | 14:30:06,909 ERROR [FieldManager] Column not found
INFO | jvm 1 | 14:30:06,971 ERROR [FieldManager] Column not found
INFO | jvm 1 | 14:30:06,971 ERROR [FieldManager] [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid column name 'LastRunDate'.

The Server logs show the follwing results:

2009-04-07 14:30:06,830 INFO [com.empirix.eme.web.EmeHttpSessionListener] New session: id=724B3D04FFFDC2BBC996FFDD94C17A62 created=Tue Apr 07 14:30:06 WST 2009
2009-04-07 14:30:06,830 INFO [com.empirix.eme.web.EmeHttpSessionListener] Current session time out:=1800
2009-04-07 14:30:06,830 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[eme]] action: --Action=/upgradeDatabase.do: LogonAction._upgradeDatabase()
2009-04-07 14:30:06,830 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[eme]] action: MethodLogonUser--
2009-04-07 14:30:06,877 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[eme]] action: actionForward is null:
2009-04-07 14:30:06,909 ERROR [com.empirix.admin.tabs.utils.FieldManager] Column not found
2009-04-07 14:30:06,971 ERROR [com.empirix.admin.tabs.utils.FieldManager] Column not found
2009-04-07 14:30:06,971 ERROR [com.empirix.admin.tabs.utils.FieldManager] [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid column name 'LastRunDate'.


Thanks
Twinkle

Best Answer

  • vTester
    vTester Member Posts: 20
    Answer ✓
    OATS product's Databases are designed to upgrade successfully from 2 to 3 releases up. Being that you are trying to upgrade a database that belongs to a version five releases earlier, you will have to raise a Service request on metalink and be prepared to send the database to Support.

Answers

  • vTester
    vTester Member Posts: 20
    Answer ✓
    OATS product's Databases are designed to upgrade successfully from 2 to 3 releases up. Being that you are trying to upgrade a database that belongs to a version five releases earlier, you will have to raise a Service request on metalink and be prepared to send the database to Support.
This discussion has been closed.