Forum Stats

  • 3,854,224 Users
  • 2,264,341 Discussions
  • 7,905,614 Comments

Discussions

Error updating Server Instance DefaultServer ports: (null)

Ankit Gupta-Oracle
Ankit Gupta-Oracle Member Posts: 11 Employee
edited Aug 21, 2009 1:16AM in JDeveloper and ADF
I have JDeveloper 11g, when I try to start the server by clicking Run > Start Server Instance I get this error:
**** Error updating Server Instance DefaultServer ports: (null)
[Server Instance DefaultServer was not started]

The IntegratedWLSConnection tests are also failing as server is not up.

To me it seems to be some configuration issue but I don't know which setting to change.
I have been facing this problem for a quite a time, please help me out with this otherwise I have no option other than re-install.

I am able to start the server from DefaultDomain > startWebLogic.cmd on the default port 7101.

Answers

  • 625743
    625743 Member Posts: 4
    edited Jul 16, 2009 7:33AM
    I am also getting this problem. I have just installed Studio Edition Version 11.1.1.1.0 and update a project from the previous version

    Edit:
    Now fixed - see later message

    Edited by: user622740 on 16-Jul-2009 04:33
  • Arunkumar Ramamoorthy-Oracle
    Arunkumar Ramamoorthy-Oracle Member Posts: 5,880 Employee
    Can you try by renaming the system folder and then invoke jdev, start the server and see if it works?
  • 625743
    625743 Member Posts: 4
    edited Jul 17, 2009 3:22AM
    OK, I've fixed the problem. I discovered that when I created a database connection I got an error message saying that there was an illegal character in the path at index 30

    file:\C:\DOCUME~1\U08654\LOCAL SETTINGS\TEMP

    Index 30 is the space character. It took me a while to work out that our desktops have the generation og 8.3 names disabled, by setting

    HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisable8Dot3NameCreation=1

    I think this must have been set by desktop after installation, when the 8.3 name for "Documents and Settings" had already been created. Anyway I changed the temp directory (I changed both environment variables TMP and TEMP, I don't know which JDeveloper uses) to

    C:\DOCUME~1\u08654\Temp

    I also created an actual directory at that location!

    I restarted JDeveloper and started with a completely fresh workspace. The create network connection worked without the error pop-up, and the server started without the "Error updating Server Instance DefaultServer ports: (null)" message.

    Note that these steps were not necessary for the JDeveloper 11.1.1.0.2 release, which worked fine with a TEMP path containing spaces, so I think this is a minor regression with the later version.

    Edited by: user622740 on 17-Jul-2009 00:21 - title change to show thai I have fixed it
    625743
  • 712415
    712415 Member Posts: 4
    Hello,

    Even i m getting the same error while Starting the default server.Port is 7101. I have just installed Studio Edition Version 11.1.1.1.0 and update a project from the previous version.Below is the error message.

    ****** Error updating Server Instance DefaultServer ports: (null)**
    **[Server Instance DefaultServer was not started].**

    Please let me know the appropriate fix for this.

    Thanks,
    -Santosh.
  • 625743
    625743 Member Posts: 4
    See post before yours in this thread for how I fixed this problem
  • Ankit Gupta-Oracle
    Ankit Gupta-Oracle Member Posts: 11 Employee
    Re-Install also did not help.

    I also have one more strange problem. The Integrated Weblogic Server Connection vanishes everytime I open JDeveloper. So I have to create it manually before deploying the application.
  • Ankit Gupta-Oracle
    Ankit Gupta-Oracle Member Posts: 11 Employee
    Hi Guys

    I finally got it working.

    This space in the path to window's temp directory was causing these issues.
    I resolved this issue by changing the Environment Variables(change both User and System Variables) TEMP and TMP from
    C:\Documents and Settings\USERNAME\Local Settings\Temp
    to C:\WINDOWS\TEMP.

    Now I am able to start the Integrated Weblogic Server from inside as well the IntegratedWLSConnection is not vanishing now.

    :):):):)Cheers:):):):)
    Ankit
This discussion has been closed.