Forum Stats

  • 3,826,042 Users
  • 2,260,590 Discussions
  • 7,896,773 Comments

Discussions

"oraops10.dll" is not found

707508
707508 Member Posts: 10
edited Jan 11, 2011 8:23PM in Oracle Provider for OLE DB
Hi All,

I have installed oracle 9i and oracle 10g in my machine. While i am trying to connect oracle 10g from .NET application, i got the below erroer message.

oraops10.dll not found.

But it is available in the machine.

can we use two version in a single machine? will it raise any issue?

Answers

  • 621554
    621554 Member Posts: 12
    I had the same problem only earlier this week. You need to go to your OracleHOME_BIN, right click and choose properties, choose the security tab and add ASP.NET User with read and write permissions
  • 774342
    774342 Member Posts: 3
    Great answer. I had the same error, tried your solution, and that worked for me.

    We had both the Oracle 10 and 11g client installed on the same machine, and thought it was conflicting.

    We moved our 10g portlets to another box, with only the 10g client installed, set ORACLE_HOME to point to the install path (in our environment variables/paths).

    It didn't work (missing the oraops10.dll, despite it's presence in the folder) until we added the ASPNET user w/ read/write access to the /BIN/ directory of our 10g client install.

    Makes perfect sense.

    Thanks!
  • gdarling - oracle
    gdarling - oracle Member Posts: 2,034
    edited Jan 11, 2011 8:23PM
    Note also that the 10203 and later client patch (10205 is current) also resolves this behavior (it runs a utility that fixes the permissions). You probably want to be using 10205 anyway rather than 10201, due to the number of bug fixes, performance enhancements and such.

    To get to 10205 patch level, apply the 10205 rdbms patch to the Oracle client software.

    Greg
This discussion has been closed.