Forum Stats

  • 3,853,958 Users
  • 2,264,299 Discussions
  • 7,905,517 Comments

Discussions

Problem installing Oracle WLS in Eclipse Ganymede

705358
705358 Member Posts: 2
edited Jul 30, 2009 10:56AM in Enterprise Pack for Eclipse
Hi,

I am running Eclipse 3.4.2 (Gan.) on Windows XP. interaction with 'Bea wls 9.2' from Eclipse is ok.
I have to create a jaxws web service on wls and installed OEPE 11.1.1.2.0 (this includes also web tier tools, wls tools, common tools).

The I downloaded 'oepe11_wls1031.exe' and the installation of 'oracle wls 10.3' looks ok. I installed on a different bea_home, used the domain creation wizard and I can start the server (startWebLogic.cmd) and it's admin console (I used another port 7002 for 10.3, 7001 in use by 9.2).

Now in Eclipse Windows Preferences I have several installed jre's: Bea 9.2, oracle wls 11gR1, jdk1.5.0_16 and jdk1.6.0_13).
In the Eclipse server tab I try to install a new oracle wls 10.3. Choices are: 'oracle wls 10gR3' and 'oracle wls 11gR1'.

Question 1: why can I choose 11gR1 in Eclipse when I installed wls 10.3?
Question 2: why do the oracle wls have a red icon ('stopped' icon)?

When I choose 'oracle wls 10gR3' in combination with (in Eclipse) 'jdk1.6.0_13 jre' or 'oracle wls 11gR1 jre': "Eclipse needs to be running on a Java VM version 6.0 or newer". When I choose 'oracle wls 11gR1' in combination with (in Eclipse) 'jdk1.6.0_13 jre' or 'oracle wls 11gR1 jre' this message does not appear.
Question 3: does this make sense?
Question 4: how can I install this server, waht should I do?

When I continue with 'oracle wls 11gR1' in combination with (in Eclipse) 'jdk1.6.0_13 jre' or 'oracle wls 11gR1 jre' after choosing the domain the error is: "The server is invalid. Error occurred reading server credential. If the domain was recreated, the server instance in Eclipse must also be recreated. Required classpath for credential detection is missing. Detection is disabled." Rather cryptic for me. I could understand a message like: the 11gR1 server is not installed.
Question 5: is it correct that I should not try to install the 11gR1 server when I installed 'oepe11_wls1031'?

Thanks for your time.
Tagged:

Answers

  • 670909
    670909 Member Posts: 1
    Question 1: why can I choose 11gR1 in Eclipse when I installed wls 10.3?

    OEPE is designed to work with multiple versions of WLS, so the 11gR1 version of OEPE will allow you to develop for WLS 11gR1, WLS 10.x, and WLS 9.2.

    As a note: the installer was labelled 10.3.1, which was an internal version number for 11gR1. It looks like the installer was mis-labelled.


    Question 2: why do the oracle wls have a red icon ('stopped' icon)?

    I am not sure what "stop" icon you mean. Are you referring to white 'O' on a red background? That would be an Oracle icon.



    Question 3: does this make sense?
    Question 4: how can I install this server, waht should I do?

    OEPE is warning you that WLS and Eclipse need to be started with the same JVM. WLS 10gR3, I think, was able to run on Java 5. You need to make sure that it is set up to run against Java 6 (if OEPE is launched with Java 6)


    Question 5: is it correct that I should not try to install the 11gR1 server when I installed 'oepe11_wls1031'?
    As I said, that OEPE should work with WLS 11gR1.
    Is there server defined under the BEA HOME for the WLS installation?
    670909
  • 705358
    705358 Member Posts: 2
    Thanks for your answer.

    I installed 10.3.0 (server103_win32.exe) and now it works.I believe it should have worked with 10.3.1 as well, isn't it?
    As a note: the installer was labelled 10.3.1, which was an internal version number for 11gR1. It looks like the installer was mis-labelled.
    Which "installer" do you mean?

    I am not sure what "stop" icon you mean. Are you referring to white 'O' on a red background? That would be an Oracle icon.
    I would never have guessed, because the o is a horizontal ellipse.

    OEPE is warning you that WLS and Eclipse need to be started with the same JVM. WLS 10gR3, I think, was able to run on Java 5. You need to make sure that it is set up to run against Java 6 (if OEPE is launched with Java 6)
    I see, would the following scenario explain my problem: I installed 10.3.1 while my PATH variable was on Java 5, then I discoverd that this OEPE requires Eclipse to run on Java 6, I changed the PATH variable, but 10.3.1 sticked somehow to Java 5? And that I iinstalled 10.3.0 with PATH set to Java 6, so that it worked?

    Is there server defined under the BEA HOME for the WLS installation?
    How can I see whether a server is defined? I configure the servers via Eclipse by choosing or creating a domain. The admin console is always present.
  • It sounds like you got your questions answered. Both WLS 11gR1 (aka 10.3.1) and WLS 10gR3 (aka 10.3.0) require Eclipse to be running in a Java 6 VM. Sometimes it is difficult to know which VM Eclipse will discover by default. You can check the VM selection by going to Help -> About -> Configuration Details and then search for java.home or java.version. If the wrong VM is being selected by default, you can tell Eclipse to use a specific VM by editing eclipse.ini file located in the root of your Eclipse install and adding two lines like the following to the start of the file:

    -vm
    c:/jre/bin/javaw.exe

    Reading through your message, it seems like there is a problem with VM version check in OEPE. You were not stopped when trying to use 11gR1 on an older VM. We will investigate that.

    - Konstantin
This discussion has been closed.