Forum Stats

  • 3,826,626 Users
  • 2,260,682 Discussions
  • 7,897,041 Comments

Discussions

Blank page instead of ADF Template output in RIA Tutorial - Jdev 11.1.1.1.0

731259
731259 Member Posts: 7
edited Nov 2, 2009 6:44AM in JDeveloper and ADF
After installing Oracle XE and Jdeveloper 11.1.1.1.0, I executed the RIA tutorial that can be found at [http://www.oracle.com/technology/obe/obe11jdev/bulldog/ria_application/developriaapplication_long.htm]. The first part went fine, but creating the display controller didn't work. Creating a new JSF page using the "Oracle Three Column Layout" should open the visual editor with something looking like this:

[http://www.oracle.com/technology/obe/obe11jdev/bulldog/ria_application/images/t042.gif]

What I got was this:

[http://img692.imageshack.us/img692/3645/jdevfakap.png]

I tried creating a page using a three column "quick layout", and it looked exactly the same. I have to admit that I have no experience with JSF at all, so my best guess is that some part of the rendering framework doesn't work properly, but I wouldn't know how to find the error as there are no error messages or log entries at all that indicate what's going wrong. I'm quite sure that I am not at fault as I only followed the tutorial - this was the first thing I did after installing the software, so I don't expect the installation to be messed up (yet).

I would be very grateful for any assistance as I was asked to evaluate if the Oracle products might be something we want to advertise to our customers. I really like what I've seen up to that point, but basic functions of the tutorial that fail consistently are not really what I was expecting. :-/

Thanks for any help I can get,

Gregor

Answers

  • RenanMC
    RenanMC Member Posts: 113
    Hi,
    see if you got the .jar file on the Jdev directory:
    <Middleware directory>\jdeveloper\adfv\jlib

    It is inside oracle-page-templates.jar on \oracle\templates

    If the problem persists at least you can do a manual insert of the template using new > jsf template
  • 731259
    731259 Member Posts: 7
    edited Oct 30, 2009 10:15AM
    The Jar file is there and it's also in the libraries in the project explorer tree.

    One thing I noticed makes me think that something at the core of the designer must be broken. When I set "Show Libraries" in the project explorer, I see the "Oracle Page Templates" Jar right there. I can open that one an I see that there's a template named "oracle.templates.threeColumnTemplate.jspx" in the Jar. When I double-click that template, I get the same empty view I described above.

    This looks to me as if the JSF rendering in my JDeveloper installation may be fundamentally broken - at least I haven't been able to do anything that would have had the result of showing anything correct in the designer view.

    Edited by: user1086802 on 30.10.2009 07:14
  • RenanMC
    RenanMC Member Posts: 113
    edited Oct 30, 2009 10:24AM
    Then, try to start a new application and do a right-click on project and new > jsf-template
    copy the oracleThreeColumn source code, insert it there and see if it works...

    The oracle-page-templates.jar isn't on my project libs and is working perfectly.

    +"This looks to me as if the JSF rendering in my JDeveloper installation may be fundamentally broken"+
    If the new app don't work this is the probably unique answer...

    Edited by: RenanMC on 30/10/2009 07:24
    RenanMC
  • 731259
    731259 Member Posts: 7
    Thanks for the debugging advice! I created a new application (ADF Application) and added a new JSF template. I switched to the source view and pasted the contents of threeColumnTemplate.jspx. When I switched to the design view, I got the expected result:

    [http://img682.imageshack.us/img682/9762/jdevfakap2.png]

    I guess I'll try a reinstall of JDeveloper on monday, but right now I guess I'll simply forget about it for the weekend. Have a nice day and thanks for the help!
  • Shay Shmeltzer-Oracle
    Shay Shmeltzer-Oracle Director of Product Management for Oracle's Cloud Development Tools Posts: 16,867 Employee
    This is the first time I hear about anyone having problem with this.
    What does your source looks like after you create the page based on the three column template?
  • 731259
    731259 Member Posts: 7
    I supposed it's not really a common error - I guess that one would have been noticed in quality control. ;)

    The source of the generated DeptEmpPage.jspx looks as follows:

    ---
    <?xml version='1.0' encoding='windows-1252'?>
    <jsp:root xmlns:jsp="http://java.sun.com/JSP/Page" version="2.1"
    xmlns:f="http://java.sun.com/jsf/core"
    xmlns:h="http://java.sun.com/jsf/html"
    xmlns:af="http://xmlns.oracle.com/adf/faces/rich">
    <jsp:directive.page contentType="text/html;charset=windows-1252"/>
    <f:view>
    <af:document id="d1">
    <af:form id="f1">
    <af:pageTemplate viewId="/oracle/templates/threeColumnTemplate.jspx"
    id="pt1">
    <f:facet name="center"/>
    <f:facet name="header"/>
    <f:facet name="end"/>
    <f:facet name="start"/>
    <f:facet name="branding"/>
    <f:facet name="copyright"/>
    <f:facet name="status"/>
    </af:pageTemplate>
    </af:form>
    </af:document>
    </f:view>
    </jsp:root>
    ---

    Not sure if that's what one should expect as I'm new to the technology - but it looks a bit empty.

    There is one thing that came to me on the weekend: I installed jDev in "program files" instead of going with the default location of "C:\oracle" - installing stuff in the root directory feels a bit to "1992" for me to be comfortable with it. I'll uninstall jDeveloper and give it a nother try using the default directory later today - perhaps there's just some component that doesn't like spaces in path names.
  • 731259
    731259 Member Posts: 7
    I talked to one of our Oracle guys today and described my problem. The man couldn't explain it, until I mentioned that I had dared to install JDeveloper in "C:\Program Files\Oracle\Middleware" instead of "C:\Oracle\Middleware". That seemed natural to me as the installation of software in the root folder was a terrible thing to do in 1995, and it's even more so now. Our Oracle guy told that installing anything from Oracle with a path containing spaces will result in tears and desperation, thought, so I went through the rather lengthy process of uninstalling JDev and XE and re-installed using the default paths.

    Everything works now.

    I sincerely hope that there's something else that could explain what I experienced. If the application really died because of a path containing a space character, this would actually make me cry. As uninstalling everything, cleaning out the registry and re-installaing takes quite some time and I'm not prepared to waste another day just to find out what the problem was, I guess I'll just let this case rest.
  • John Stegeman
    John Stegeman Member Posts: 24,269 Blue Diamond
    Hi,

    Sorry you had so much trouble. Yes, the "space in a path" issue is documented in the release notes for JDeveloper as a no-no, don't know about Oracle XE, but I haven't heard of similar issues there.

    Uninstalling/reinstalling JDeveloper shouldn't require you to do anything with the registry.

    John
    John Stegeman
  • 731259
    731259 Member Posts: 7
    I always clean up the registry after unisntalling software - you never know if something might be left there. In this case you are right, though, I found no remnants of JDeveloper.

    The space-in-path problem is quite embarrasing, if you ask me, but I can imagine how something like that can lurk in a big hunk of software like JDeveloper. If it's a known issue, it should be mentioned in the installer, though. While Oracle XE didn't even allow the installation in a directory with spaces in the name, JDeveloper didn't warn about it. A little update of the installer that contains the necessary path validation would be an acceptable workaround until the underlying problem is fixed.
  • 731259
    731259 Member Posts: 7
    Even though JDeveloper worked properly after reinstalling, I couldn't start up the integrated Weblogic Server. The log showed that JAVA_HOME pointed to the wrong directory - actually to the directory in which I had installed JDeveloper before.

    The problem was that the unistaller for JDeveloper didn't remove the file %USER_HOME%\AppData\Roaming\JDeveloper\system11.1.1.1.33.54.07\DefaultDomain\bin\setDomainEnv.cmd - and that one sets ORACLE_HOME, WL_HOME and stuff like that. The installer didn'T overwrite that file when re-installing, either, so I had to manually edit the file in order to get the proper paths.

    Come on, people, stuff like that shouldn't happen when you work with software that's supposed to be state-of-the-art enterprise piece-of-the-heavens software.
This discussion has been closed.