Forum Stats

  • 3,854,961 Users
  • 2,264,441 Discussions
  • 7,905,847 Comments

Discussions

ADF with Desktop Integration

SamsonFu
SamsonFu Member Posts: 139
edited Dec 2, 2009 8:52PM in JDeveloper and ADF
Hi all,

Have you tried the MasterPriceList application from Fusion Order Demo R1? I cannot perform the "Edit using Live Spreadsheet" from my computer.
When I set the configuration according to the Integrated Excel Workbook : http://download.oracle.com/docs/cd/E12839_01/web.1111/e10139/deploy_app.htm
I found unable to set this item:
6.Click Add new location and enter the host name of the Fusion web application in the Path field of the dialog box that appears.
For example, you enter something similar to the following for the Master Price List module of the Fusion Order Demo application:
http://hostname:8988/FODMasterPriceList
The Excel do not allow to use http:// in the Trusted Locations:
The path you have entered cannot be used as a trusted location for security reasons
I have installed the Desktop Integration Excel Client and enabled Allow Trusted Locations on my network (not recommended) checkbox according to the guide.

How do you make the Edit using Live Spreadsheet work?

Regards,
Samson Fu
Tagged:

Answers

  • Arunkumar Ramamoorthy-Oracle
    Arunkumar Ramamoorthy-Oracle Member Posts: 5,880 Employee
    Hi,

    What is the error you are getting when you add the URL to trusted location?

    -Arun
  • SamsonFu
    SamsonFu Member Posts: 139
    Hi Arun,

    The error is:
    The path you have entered cannot be used as a trusted location for security reasons
    Regards,
    Samson Fu
  • Arunkumar Ramamoorthy-Oracle
    Arunkumar Ramamoorthy-Oracle Member Posts: 5,880 Employee
    Hi Samson,

    Couple of things to check.

    1. Can you double check that you've checked the option "Allow Trusted Locations on my network (not recommended)" ? I noticed that you've checked it. But, the error message clearly indicates that the issue could be because of not allowing trusted locations on the network.
    2. Are you entering the host name or the IP address? AFAIK, you cannot add ip addresses for security reasons. You either need to give the hostname / localhost (if the server is running on your local machine).

    -Arun
  • SamsonFu
    SamsonFu Member Posts: 139
    1. Can you double check that you've checked the option "Allow Trusted Locations on my network (not recommended)" ? I noticed that you've checked it. But, the error message clearly indicates that the issue could be because of not allowing trusted locations on the network.
    I am very very sure the option is checked. Since I notice the problem may related to this options, so I've verify many times.
    2. Are you entering the host name or the IP address? AFAIK, you cannot add ip addresses for security reasons. You either need to give the hostname / localhost (if the server is running on your local machine).
    I've tried both IP address and hostname (localhost and remote computer) but no success. I've tested on other computers (PC Controlled by domain controller, and Standalone PC just installed Windows & Office) but all failed. I think the Office do not allow Trust Address begin with "http" by default.

    Regards,
    Samson Fu
  • Arunkumar Ramamoorthy-Oracle
    Arunkumar Ramamoorthy-Oracle Member Posts: 5,880 Employee
    Well. You can very well add the http urls.

    http://technet.microsoft.com/en-us/library/cc179039.aspx#section1

    However, there is a rule ;).
    http://hostname:port        ===> Not accepted (even if you check the "Subfolders of this location are also trusted" check box)
    http://hostname:port/       ===> Not accepted (even if you check the "Subfolders of this location are also trusted" check box)
    http://hostname:port/context_root/   ==> Accepted
    So, i feel, you are just entering the hostname and port and not the context root. Please check.

    -Arun
    Arunkumar Ramamoorthy-Oracle
  • SamsonFu
    SamsonFu Member Posts: 139
    Thank you Arun, I did not include context_root before.
    The Excel Trust Site Settings is work now.
    I found other problems, but that should be another thread.

    Regards,
    Samson Fu
This discussion has been closed.