Forum Stats

  • 3,816,305 Users
  • 2,259,168 Discussions
  • 7,893,452 Comments

Discussions

Character changing when inserting into Oracle

979621
979621 Member Posts: 6
edited Dec 13, 2012 9:48AM in Oracle Provider for OLE DB
This is a re-post of a question that was incorrectly put in the globalization forum.
2477635

I am debugging an old web service which is using Enterprise Services. The service is sitting in IIS 6 using .NET 4. A new problem appeared when an insert statement was generated that attempted to insert a string which included a degree symbol. When executed, the degree symbol is changed to an upside down question mark. No error messages were generated.

The strange thing is that I took a copy of the assemblies and dropped them on a test machine (same OS and IIS) and the insert statement worked. I've been trying to find the difference between the two machines to determine why this is happening. It's the same code running so I know the code is not the issue. I also know that it's using the same Microsoft Oracle provider. I've examined the region/language settings and the config files in the core framework folders and everything matches.

Anyone have any idea what I'm missing or where I can look for additional settings?

Additional information:

NLS_CHARACTERSET - WE8ISO8859P1
NLS_LANGUAGE - AMERICAN
NLS_TERRITORY - AMERICA
NLS_CALENDAR - GREGORIAN
NLS_DATE_FORMAT - DD-MON-RR
NLS_DATE_LANGUAGE - AMERICAN
NLS_SORT - BINARY
NLS_TIME_FORMAT - HH.MI.SSXFF AM
This is the connection string from the object: OleDbConnection("Provider=MSDAORA.1;...

And the oracle client installed is version 10.
Tagged:

Answers

This discussion has been closed.