Forum Stats

  • 3,734,278 Users
  • 2,246,936 Discussions
  • 7,857,217 Comments

Discussions

webutil jacob-1.14.3-x86.dll 404 error

jhughes
jhughes Member Posts: 4
edited Aug 28, 2013 10:19AM in Forms
I've been following the instructions in document 1093985.1 How to Configure Webutil in Forms 11g. We have Forms 11gR2 installed. I've downloaded jacob 1.14.3, signed the jacob jar and copied the jacob dlls to $ORACLE_HOME/forms/webutil/win32 (jacob-1.14.3-x86.dll) and ORACLE_HOME/forms/webutil/win64 (jacob-1.14.3-x64.dll).

While running the webutil_demo form, we receive wuc-24: Error reading url: http://<servername:port>/forms/webutil/win32/jacob-1.14.3-x86.dll.
The java console shows: 2013-Apr-03 13:38:15.461 ERROR>WUC-24 [URLDownload.pullFile()] Error reading URL http://ovmasd1-fds.ahe.doe.gov:37888/forms/webutil/win32/jacob-1.14.3-x86.dll

When I try to retrieve the dll via the url: http://ovmasd1-fds.ahe.doe.gov:37888/forms/webutil/win32/jacob-1.14.3-x86.dll I recieve a 404.

The access log shows the following: 172.16.3.136 - - [03/Apr/2013:13:39:19 -0400] "GET /forms/webutil/win32/jacob-1.14.3-x86.dll HTTP/1.1" 404 1214

Interestingly enough, all other files in $ORACLE_HOME/forms/webutil/win32/ are accessible via a browser - I've even renamed the jacob-1.14.3-x86.dll, and the webserver finds it with no problem.

I obviously have something misconfigured, but I'm stuck - any ideas would be welcome.

Thank you.

Justin

Answers

  • CraigB
    CraigB Member Posts: 5,746
    If the jacob-1.14.3-x86.dll actually exists in the /forms/webutil/win32 directory, then you may need to have the file transfered to this directory again or check the file permissions on the file. We encountered this same error when we setup WebUtil in FMw and that was what fixed our issue.

    Hope this helps,
    Craig...
  • jhughes
    jhughes Member Posts: 4
    Thanks Craig, I've replaced the file several times, and it's world-readable - still no luck.

    Appreciate the help...
  • CraigB
    CraigB Member Posts: 5,746
    Did you FTP the file to your server and if so, did you FTP the file in binary or text mode?

    Craig...
  • jhughes
    jhughes Member Posts: 4
    I binary scpd the jacob-1.14.3.zip (downloaded from the sourceforge.net site) to my server, unzipped the contents and copied the files to the required directories.

    Justin
  • AlexDiniasi
    AlexDiniasi Member Posts: 183
    edited Apr 4, 2013 12:38PM
    Hello,

    Please perform the following:

    1. FTP again the jacob.jar and the jacob dlls.Sign the jacob.jar.

    2- Bring down WLS_FORMS and Admin managed servers

    3- Bring down nodemanager

    4- Bring down OPMN and all the processes

    5- Start again nodemanager

    6- Start again Admin and WLS_FORMS managed servers

    7- Start OPMN and all the processes

    8- Clear java cache on client machine and re-test the issue.

    Regards,
    Alex

    If someone's answer is helpful or correct please mark it accordingly.

    Edited by: AlexDiniasi on 04.04.2013 19:37
  • jhughes
    jhughes Member Posts: 4
    Alex, I took your advice, and restarted weblogic servers, and opmn components and we are no longer experiencing the wuc-24 error. Thanks very much for your help - can you explain why a restart of the servers/opmn would fix this issue?

    Justin
  • AlexDiniasi
    AlexDiniasi Member Posts: 183
    edited Apr 9, 2013 8:08AM
    Hello Jhughes,

    It is a known issue. Unfortunately, it cannot be reproduced consistently so that a bug could be logged.
    This workaround it is known to overcome the problem.

    Kind regards,
    Alex
  • user12192944
    user12192944 Member Posts: 2 Blue Ribbon
    edited Aug 27, 2013 5:23PM

    Had the same problem but then discovered after so much digging around what the webutil configuration file should look like for 11gR2. Check the new configuration file in Locations and Samples of Configuration Files - 11g Release 2 (11.1.2) (Appendix C.10 Default webutil.cfg).

    I am sure this will resolve the issue.

    Thanks,

    Muyiwa

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,644 Employee

    If you find that double checking your webutil.cfg doesn't help, be sure to stop ALL related processes (WLS_FORMS, Admin Server, Node Manager, OPMN) then restart.

    Regarding the webutil.cfg, there should be not changes required except possibly the references to Jacob.  Do NOT take config files from old installations and copy them into a new installation of a newer version.  The entries for Jacob 1.14.3 should look like this:

    install.syslib.0.0.7.1=jacob-1.14.3-x86.dll|102400|1.14.3|true
    install.syslib.0.1.7.1=jacob-1.14.3-x64.dll|117760|1.14.3|true
    
This discussion has been closed.