Forum Stats

  • 3,855,262 Users
  • 2,264,493 Discussions
  • 7,905,953 Comments

Discussions

Eclipse Mars.1 hangs when creating a new Oracle ADF application

3067745
3067745 Member Posts: 6
edited Dec 5, 2015 3:12AM in Enterprise Pack for Eclipse

All is said in the title. I tried numerous solutions, in particular :

  • Downloading Oracle Enterprise Pack for Eclipse;
  • Downloading the latest release of Eclipse Mars and then adding Oracle ADF Tools;


The symptoms are the following ones :

  • I choose to create a new ADF application;
  • I fill in the fields of the first page of the wizard;
  • When I click [Next], nothing happens but eclipse asks if I want to send an error report;
  • Eclipse is frozen and i have to kill the task;

My current environment : Windows 10 / 64 bits, jdk8u60, Version: Mars.1 Release (4.5.1), Oracle Enterprise Pack for Eclipse 12.2.1

My question : is there a known workaround ?

«1

Answers

  • Raj Alag-Oracle
    Raj Alag-Oracle Member Posts: 125
    edited Nov 8, 2015 10:21PM

    Hi,

    Could you provide some additional details such as what Windows 10 edition you are running on ? is it Home, Pro or Enterprise and the version of WebLogic Server install you are working with.

    Can you try this on your current install.

    edit eclipse.ini and add the following 2 lines are the first two entries

    -vm

    C:\<replace path>\java.exe

    this will force Eclipse to start with the specific java version and also display a console window which provides some additional debug information.

    Thanks

    Raj

  • 3067745
    3067745 Member Posts: 6
    edited Nov 9, 2015 10:15AM

    Hello Raj,

    Here is a snapshot of the Eclipse error :

    2015-11-09_16-06-41.png

    and the snapshot of the killing of the task :

    2015-11-09_16-11-44.png

    My system is Windows 10 pro x64.

    Serge

  • Raj Alag-Oracle
    Raj Alag-Oracle Member Posts: 125
    edited Nov 9, 2015 1:32PM

    Hi Serge,

    Thanks for the providing the information. Do you see this error dial when you click finish on the ADF app wizard or do you see it once Eclipse comes up ?

    Which version of WebLogic Server are you working with ?

    Have you tried running eclipse.exe in win 8/7  compatibility mode ?

    steps:

    right click eclipse.exe

    open properties

    under Compatibility, check the Compatibility mode and pick Windows 8 from the dropdown

    Thanks

    Raj

  • 3067745
    3067745 Member Posts: 6
    edited Nov 10, 2015 3:24AM

    Hello Raj,

    I downloaded ORACLE ADF Tools for Eclipse without Weblogic server. I wanted to use Glassfish with ADF essentials. I did what you asked for. The error dial appeared immediately after making [File / new / ADF application]. I input nothing. It was the same error that the one of my previous post : "Unhandled event loop exception".

    You can see the error report here.

    Serge

  • dvohra21
    dvohra21 Member Posts: 14,674 Gold Crown
    edited Nov 11, 2015 11:31AM

    Oracle Enterprise Pack for Eclipse (12.2.1) includes Eclipse. Why is Eclipse also being downloaded separately?

    http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html

  • Greg Stachnick-Oracle
    Greg Stachnick-Oracle Member Posts: 90
    edited Nov 11, 2015 11:35AM

    There are multiple distribution methods and installation options for OEPE.

    We include OEPE with the Eclipse Platform in a zip or as a Network Installer as you noted but we also provide OEPE as plugins (listed on Eclipse Marketplace) which can be installed into an existing Eclipse.

  • Raj Alag-Oracle
    Raj Alag-Oracle Member Posts: 125
    edited Nov 11, 2015 12:01PM

    Thanks for the information Serge. I tried again with the all-in-one 12.2.1 zip from OTN with WLS+JRF 10.3.6 and was able to create an ADF app on Windows 10, with JDK 1.8_65. I will try again with 1.8.0_60.

    Meanwhile, could you try upgrading to the latest JDK to see if that resolves the issue ?

    My OEPE instance is running with the following lines in eclipse.ini

    -vm

    C:\Java\jdk1.8.0_65\bin\java.exe

    -startup

    could you please attach the .log file from the workspace metedata folder and the eclipse.ini file here ?

    thanks

    Raj

  • 3067745
    3067745 Member Posts: 6
    edited Nov 13, 2015 3:12AM

    Hello Raj,

    I tried with [jdk1.8.0_66] and got the same error. Here are the two files you asked for.

    serge

    [.log]

    ======================================================

    !SESSION 2015-11-13 09:10:29.228 -----------------------------------------------

    eclipse.buildId=4.5.1.M20150904-0015

    java.version=1.8.0_66

    java.vendor=Oracle Corporation

    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR

    Framework arguments:  -product org.eclipse.epp.package.jee.product

    Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

    !ENTRY org.eclipse.ui 2 2 2015-11-13 09:10:41.945

    !MESSAGE Invalid preference category path: oracle.eclipse.tools.adf.mobile.preferences (bundle: oracle.eclipse.tools.adf.view.ui, page: oracle.eclipse.tools.adf.view.ui.OEPEPage)

    !ENTRY org.eclipse.egit.ui 2 0 2015-11-13 09:10:42.713

    !MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git

    user global configuration and to define the default location to store repositories: 'C:\Users\usrlocal'. If this is

    not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and

    EGit might behave differently since they see different configuration options.

    This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

    !ENTRY org.eclipse.ui 4 0 2015-11-13 09:10:51.277

    !MESSAGE Unhandled event loop exception

    !STACK 0

    org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.IllegalArgumentException)

      at org.eclipse.swt.SWT.error(SWT.java:4491)

      at org.eclipse.swt.SWT.error(SWT.java:4406)

      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)

      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4155)

      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3772)

      at org.eclipse.jface.window.Window.runEventLoop(Window.java:827)

      at org.eclipse.jface.window.Window.open(Window.java:803)

      at org.eclipse.ui.internal.navigator.wizards.WizardShortcutAction.run(WizardShortcutAction.java:99)

      at org.eclipse.jface.action.Action.runWithEvent(Action.java:473)

      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)

      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)

      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420)

      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

      at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4362)

      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1113)

      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4180)

      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3769)

      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)

      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)

      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)

      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)

      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:654)

      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)

      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:598)

      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)

      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:139)

      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)

      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)

      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)

      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

      at java.lang.reflect.Method.invoke(Method.java:497)

      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)

      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)

      at org.eclipse.equinox.launcher.Main.run(Main.java:1515)

      at org.eclipse.equinox.launcher.Main.main(Main.java:1488)

    Caused by: java.lang.IllegalArgumentException

      at org.eclipse.sapphire.Version.<init>(Version.java:55)

      at oracle.eclipse.tools.adf.view.ui.wizard.internal.newadfapplication.NewADFApplicationWizard.setADFWebProjectRuntimeAndDefaultFacets(NewADFApplicationWizard.java:678)

      at oracle.eclipse.tools.adf.view.ui.wizard.internal.newadfapplication.NewADFApplicationWizard.updateADFWebFacetInstallWizardPage(NewADFApplicationWizard.java:149)

      at oracle.eclipse.tools.adf.view.ui.wizard.internal.newadfapplication.NewADFApplicationWizard$1$1.run(NewADFApplicationWizard.java:193)

      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)

      ... 36 more

    [eclipse.ini]

    =============================================================

    -vm

    C:/Program Files/Java/jdk1.8.0_66/bin/java.exe

    -startup

    ../../../Users/usrlocal/.p2/pool/plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar

    --launcher.library

    ../../../Users/usrlocal/.p2/pool/plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.300.v20150602-1417

    -product

    org.eclipse.epp.package.jee.product

    --launcher.defaultAction

    openFile

    --launcher.XXMaxPermSize

    256M

    -showsplash

    org.eclipse.platform

    --launcher.XXMaxPermSize

    256m

    --launcher.defaultAction

    openFile

    --launcher.appendVmargs

    -install

    C:/Program Files/eclipse-mars/eclipse

    -vmargs

    -Dosgi.requiredJavaVersion=1.8

    -Xms256m

    -Xmx1024m

    -Doomph.update.url=http://download.eclipse.org/oomph/updates/milestone/latest

    -Doomph.redirection.index.redirection=index:/->http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/

    -Dsun.lang.ClassLoader.allowArraySyntax=true

  • Raj Alag-Oracle
    Raj Alag-Oracle Member Posts: 125
    edited Nov 13, 2015 5:42PM

    Thanks again for the information Serge. I was able to reproduce the issue with OEPE 12.2.1 and have confirmed that the issue has already been fixed in the upcoming OEPE release.

    I will update this post once this version of OEPE is available for download.

    thanks

    Raj

  • 3067745
    3067745 Member Posts: 6
    edited Nov 14, 2015 8:21AM

    Fine. So i'll wait for the new version. Thanks.

    serge

This discussion has been closed.