Forum Stats

  • 3,855,374 Users
  • 2,264,500 Discussions
  • 7,905,979 Comments

Discussions

Trying to run application on IntegratedWebLogicServer

3407371
3407371 Member Posts: 11
edited Mar 26, 2017 6:44PM in JDeveloper and ADF

Using JDeveloper 11.1.2.4.0 to build the Android app, I come across an obstacle where I cannot get SampleWS.jws to run. The error reads:

01:19:29 PM] Deployment cancelled.

[01:19:29 PM] ----  Deployment incomplete  ----.

[01:19:29 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)

#### Cannot run application SampleWS due to error deploying to IntegratedWebLogicServer.

I'd appreciate help on how to resolve this issue.

Tagged:
3407371
«1

Answers

  • Timo Hahn
    Timo Hahn Senior Principal Technical Consultant - Oracle ACE Director Member, Moderator Posts: 38,777 Red Diamond
    edited Mar 23, 2017 3:29PM

    The error message doesn't tell anything about the problem.

    Don't you see anything else in the log?

    Instead of deploying the app directly to the integrated server, can you deploy it to an ear file?

    Have you tried to start the application?

    Timo

    3407371
  • dvohra21
    dvohra21 Member Posts: 14,674 Gold Crown
    edited Mar 23, 2017 3:40PM

    How would an Android app be tested on WebLogic Server? Doesn't an Android app have to packaged into an .apk and tested on an emulator or Android device?

  • 3407371
    3407371 Member Posts: 11
    edited Mar 23, 2017 11:59PM

    Hi again! I appreciate your help but could you elaborate on how I'd go about deploying the app to an ear file? As for if I tried to start the app, the tutorial advises not to do that because the app may not function properly.

    From the log:

    [10:48:56 PM] Deploying Application...

    <Mar 23, 2017 10:48:58 PM CDT> <Error> <HTTP> <BEA-101371> <There was a failure when processing annotations for application C:\Users\Programs\AppData\Roaming\JDeveloper\system11.1.2.4.39.64.36.1\o.j2ee\drs\SampleWS\Project1WebApp.war. Please make sure that the annotations are valid. The error is Class bytes found but defineClass()failed for: 'a.Service'>

    <Mar 23, 2017 10:48:58 PM CDT> <Error> <Deployer> <BEA-149265> <Failure occurred in the execution of deployment request with ID '1490327337144' for task '0'. Error is: 'weblogic.application.ModuleException: Failed to load webapp: 'SampleWS''

    weblogic.application.ModuleException: Failed to load webapp: 'SampleWS'

      at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:393)

      at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)

      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199)

      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:517)

      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

      Truncated. see log file for complete stacktrace

    Caused By: java.lang.UnsupportedClassVersionError: a/Service : Unsupported major.minor version 51.0

      at java.lang.ClassLoader.defineClass1(Native Method)

      at java.lang.ClassLoader.defineClassCond(ClassLoader.java:630)

      at java.lang.ClassLoader.defineClass(ClassLoader.java:614)

      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

      at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:343)

      Truncated. see log file for complete stacktrace

    >

    <Mar 23, 2017 10:48:58 PM CDT> <Warning> <Deployer> <BEA-149004> <Failures were detected while initiating deploy task for application 'SampleWS'.>

    <Mar 23, 2017 10:48:58 PM CDT> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004

    weblogic.application.ModuleException: Failed to load webapp: 'SampleWS'

      at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:393)

      at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)

      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199)

      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:517)

      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

      Truncated. see log file for complete stacktrace

    Caused By: java.lang.UnsupportedClassVersionError: a/Service : Unsupported major.minor version 51.0

      at java.lang.ClassLoader.defineClass1(Native Method)

      at java.lang.ClassLoader.defineClassCond(ClassLoader.java:630)

      at java.lang.ClassLoader.defineClass(ClassLoader.java:614)

      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

      at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:343)

      Truncated. see log file for complete stacktrace

    >

    [10:48:58 PM] Deployment cancelled.

    [10:48:58 PM] ----  Deployment incomplete  ----.

    [10:48:58 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)

    #### Cannot run application SampleWS due to error deploying to IntegratedWebLogicServer.

    [Application SampleWS stopped and undeployed from Server Instance IntegratedWebLogicServer]

  • SanjeevChauhan
    SanjeevChauhan Member Posts: 1,554 Gold Trophy
    edited Mar 24, 2017 12:14AM

    This seems to be issue of a.Service class being compiled on JDK 1.7 but you are trying to run it on JDK 1.6

    Which version of JDK you are using in jdeveloper?

    Which version of JDK is used by your weblogic?

    Is a.Service coming from a library or its your own class in project?

    Thanks

    Sanjeev

    3407371
  • 3407371
    3407371 Member Posts: 11
    edited Mar 24, 2017 12:43AM

    Yes, I'm using JDK 1.7 for JDeveloper and JDK 1.6 for weblogic. In the beginning I was running into so many hurdles that I was willing to download anything I thought was necessary to get the emulator running.

    a.Service comes from the SampleWS.zip file.

  • SanjeevChauhan
    SanjeevChauhan Member Posts: 1,554 Gold Trophy
    edited Mar 24, 2017 1:05AM

    You can't deploy a 1.7 compiled file on 1.6. I believe you should change JDK of weblogic to move to 1.7 or start developing with 1.6 JDK in jdeveloper.

    To change jdev's jdk version you can follow Mark's Blog: Change JDK used by JDeveloper

    To change weblogic jdk version you can follow My work: Changing Weblogic Configuration to use newer version of JDK

    Thanks

    Sanjeev

  • 3407371
    3407371 Member Posts: 11
    edited Mar 24, 2017 3:29AM

    I gave it a try by using jdk160_24 for JDeveloper but nothing changed. Thanks anyway, Sanjeev!

  • 3407371
    3407371 Member Posts: 11
    edited Mar 24, 2017 11:18PM

    Hi, do you still have any more suggestions?

  • dvohra21
    dvohra21 Member Posts: 14,674 Gold Crown
    edited Mar 25, 2017 8:31AM

    Caused By: java.lang.UnsupportedClassVersionError: a/Service : Unsupported major.minor version 51.0

    "I gave it a try by using jdk160_24 for JDeveloper"

    It is not the JDeveloper version which needs to be changed, but the JDeveloper Java Compiler version.

    The Java version to use should be supported based on Oracle JDeveloper 11g Release 2 (11.1.2) Certification

    JDeveloper 11.2.4 has some Java version related issues, use a different JDeveloper version preferrably, but if not please refer

    Notes:

    -JDK 7 supported added in 11.1.2.4.0.

      • There is a known, serious issue with this version of JDeveloper running with Oracle JDK 1.7 Update 25. For more information, see the issue for JDK 1.7 Update 25 (16710919) in the release notes,
      • JDeveloper bundles Integrated WLS 10.3.5, which does not support JDK 7. To use JDK 7 for JDeveloper and Integrated WLS, you can install WLS 10.3.6 separately and create an "Integrated Server" connection to it from JDeveloper.

    -32 bit JDK required for profiling features.

    -For JDK 6, update 39 or later is recommended; for JDK 7, update 10 or later is recommended

    -On Mac OS 10.5 Java for Mac OS X 10.5 Update 8 or later is recommended, on Mac OS 10.6 Java for Mac OS X 10.6 Update 3 or later is recommended

  • 3407371
    3407371 Member Posts: 11
    edited Mar 25, 2017 8:59PM

    Thank you for your help but there are still some tasks I can't do.

This discussion has been closed.