Forum Stats

  • 3,837,472 Users
  • 2,262,260 Discussions
  • 7,900,290 Comments

Discussions

Jasper Reports error

user8769643
user8769643 Member Posts: 203
edited Mar 26, 2017 10:14PM in Java Programming

Hello all - i am a newbie and having issues building my project which has some jasper dependencies. I see the error below

Caused by: java.lang.ClassNotFoundException: net.sf.jasperreports.engine.JasperReportsContext  at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)  at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)  at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)

I have plugin defined in my pom.xml and also i see jasperreports-5.2.0.jar in my build path. can someone help me why it says it's still missing the class.

      <plugin>          <groupId>com.alexnederlof</groupId>            <artifactId>jasperreports-plugin</artifactId>            <version>1.8</version>            <executions>                <execution>                    <phase>process-sources</phase>                    <goals>                            <goal>jasper</goal>                    </goals>                </execution>            </executions>        <configuration>          <outputDirectory>${project.build.directory}/${project.name}-${project.version}/reports</outputDirectory>          <compiler>net.sf.jasperreports.compilers.JRGroovyCompiler</compiler>        </configuration>        <dependencies>    <dependency>      <groupId>com.lowagie</groupId>      <artifactId>itext</artifactId>      <version>2.1.7</version>   </dependency>     <dependency>        <groupId>net.sf.jasperreports</groupId>        <artifactId>jasperreports</artifactId>        <version>5.2.0</version>     </dependency>     <dependency>        <groupId>log4j</groupId>        <artifactId>log4j</artifactId>        <version>1.2.14</version>          </dependency>          <dependency>            <groupId>org.codehaus.groovy</groupId>            <artifactId>groovy-all</artifactId>            <version>1.8.3</version>          </dependency>        </dependencies>      </plugin>

Thank you for your help in advance.

Answers

This discussion has been closed.