Forum Stats

  • 3,851,666 Users
  • 2,264,010 Discussions
  • 7,904,813 Comments

Discussions

Problem with implementing Maven into WBS(UI components not recognized by JDeveloper)

Robert Šajina
Robert Šajina Member Posts: 94
edited May 11, 2017 7:53AM in JDeveloper and ADF

Hi,

I am having trouble implementing Maven into work breakdown structure.

image

I have tried working with JDeveloper libraries and dependencies which worked fine, but i want to work with Maven as JDeveloper has support for it, and it would be easier to maintain library and dependencies.

My problem is that when i "install" subsystem and include the subsystem library in my master project i don't see my subsystem task flows. Also happens with templates in Common work space which i can't use in any other project (Master or Subsystem).

I' m not having problems in the Model(Business Components) project where if i create an entity in Common Model i can easily see it in my Subsystem work space when creating View Objects. So the problem only occurs in the view controller project.

I have a declarative component which i included in subsystem and to make it visible in the Components Pallet i had to manually add it in Facelets Tag Libraries (ViewController->Project Properties->Facelets Tag Libraries). When using pure JDeveloper library management it is automatically added.

So i am wonder there is a workaround for templates or task flows, or am I missing something?

I have done some researching and found this post which is similar to my problem, but its not quite clear to me how to make it work.

jsf - Using Maven dependencies in JDeveloper 12c - Stack Overflow

My JDeveloper version is 12.2.1.2.0. with JDeveloper build in Maven 3.2.5.

Tagged:

Answers

This discussion has been closed.