Forum Stats

  • 3,836,764 Users
  • 2,262,184 Discussions


Getting ORA-01031: insufficient privileges when trying to run ords.enable_schema

Mark Sta Ana
Mark Sta Ana Member Posts: 16

I've been able to get ORDS standalone (connected to Database A) running locally via SQL Developer. I'm now trying to install it (connected to Database B) using instructions provided by Tim Hall's excellent resource:

I've also checked the install against the following instructions: Installing Oracle REST Data Services

When I try to enable rest service for a schema on Database B. I get the following error.

So far the only difference I can tell between this install and the ORDS install for Database A  is my chosen schema has a proxied user to ORDS_PUBLIC_USER. So I tried to mimic this on Database B using alter user my_schema grant connect through ORDS_PUBLIC_USER;

I've run java -jar ords.war validate and can see no errors in the log.

I even tried create an admin user java -jar ords.war user adminlistener "Listener Administrator" so I could use the REST Data Services > Admininistration feature. I've connected to the ORDS on Database B, but when I right click on Database B in the Connections panel there's no Enable REST services.

Kiran Pawar


This discussion has been closed.