Forum Stats

  • 3,825,902 Users
  • 2,260,573 Discussions


Receive "Issues with the configuration of the Static Files" error after ORDS 18 install and configur

PhilMan2 Member Posts: 380 Bronze Badge


I'm using XE 18C on a Windows platform.  I installed Apex 18.2 and then installed ORDS 18.4.  I followed the instructions in section in the install guide… 

When I was prompted for "Enter the Apex static resource location" I responded with C:\app\product\apex\images

The install went without an error.  I looked at all the logs in C:\Users\(my_username).  Not a single mention of "error" or "warning".

In the Apex install guide, section 4.6 it instructs to copy the Apex images folder to ORDS.  I copied C:\app\product\apex\images to C:\app\product\ords.  Then I ran @apex_rest_config.sql from SQL Plus.  It seemed to complete OK.

When I attempt to access Apex through a browser (localhost:9090/ords/apex) I receive a popup error: "There are issues with the configuration of the Static Files in your environment.  Please consult "Configuring Static File Support" section in the Application Express Install Guide."

If I click OK on the prompt I can continue on to the Apex logon screen.  I'm able to login and get to the first screen.  However I want to address the error before proceeding further.

Any ideas why I'm getting this error?  Thanks for looking at this.

ThompsonBrian Lester

Best Answer

  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 15, 2019 8:32AM Answer ✓

    These were the steps I took.

    create a tnsnames.ora entry for the pluggable database.
    test the pluggable tnsnames.ora entry OUTSIDE of the server using the SYS account.
    XE 18C
    sqlplus / as sysdba
    alter session set container=pluggable_db_name
    e:\apex18.2\apex directory -  using SQLPLUS> @apexins SYSAUX SYSAUX TEMP /i/
    Verify apex install:
    select status from dba_registry where comp_id='APEX';
    Rem  ALTER system SET shared_servers=5 scope=both;
    @apex_epg_config.sql E:\apex182  (apex installation home - my images are at: E:\apex182\apex\images)
    commit; (may or may not be needed)
    create the ords.war file at this point.

    Good practice is to install the ORDS in its own home (E:\ords for example).
    I see a lot of folks on this forum that recommend this approach.

    Test out all of your accounts used/unlocked too.
    Note that I did an alter session set container before I ran all of  .sql scripts
    above.  Use the pluggable passwords in the

    You can also validate the ords install and look for any  issues:

    java  -jar E:\ords\ords.war validate

    Brian Lester


  • PhilMan2
    PhilMan2 Member Posts: 380 Bronze Badge
    edited Mar 9, 2019 10:27AM

    The text in the APEX install guide for static images has a link to the ORDS install guide. Therefore, I assume that this problems belongs in this forum?

    When I installed APEX 18.2 I extracted all the files and then from SQL PLUS (SYS as SYSDBA) I ran the statements:

    @apexins SYSAUX SYSAUX TEMP /i/ ;

    @apxchpwd ;

    This has always worked with prior releases.

  • PhilMan2
    PhilMan2 Member Posts: 380 Bronze Badge
    edited Mar 11, 2019 8:35AM

    The file is located in C:\app\product\ords\standalone\  The contents are:

    #Mon Mar 11 08:12:28 EDT 2019






    The file is located in C:\app\product\ords\params\  The contents are:

    #Mon Mar 11 08:29:24 EDT 2019


















    Is there anything wrong with the contents of these files?

  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 11, 2019 11:18AM

    I am by far no expert of APEX and ORDS (my disclaimer especially since I will be opening my own issue here today).  Nonetheless I have also had issues with the file.  I've typed things in there that didn't work and I've also seen changes in there (I watched the timestamp).

    Try working around this file at first by using some switches like this:

    java -jar ords.war standalone --apex-images C:\app\product\apex\images

    It might be worth trying to run the standalone command and adding in each parameter by hand too.  It's a lot to type or paste but it eliminates that properties file as the source of your problems.

    java -jar ords.war standalone

    Other helpful info:  java -jar ords.war help standalone

  • PhilMan2
    PhilMan2 Member Posts: 380 Bronze Badge
    edited Mar 11, 2019 12:34PM

    Hello user12094070.  Thanks for looking at this.

    I tried your suggestion and got the same result.  at C:\app\product\ords\ I input the following:

    java -jar ords.war standalone --port 9090 --apex-images c:/app/producdt/apex/images --context-path /ords --static-context-path /i

    I still get the warning message.  I can continue on to Apex Admin where the screens appear normal, but the warning concerns me and I hate to proceed further.  I fear the problem will show up later on.

    Do you have other suggestions?

  • PhilMan2
    PhilMan2 Member Posts: 380 Bronze Badge
    edited Mar 11, 2019 4:04PM

    Hello JeffSmith,

    Thanks for responding.  I hadn't seen that link, so this is very helpful.  I started following it, but ran into a problem.  When I run @apex_rest_config.sql I get an error similar to one that was reported in January 2019.  Apex 18.2 - GetConsoleMode failed, LastError=|6| while running @apex_rest_config.sql for ORDS

    I indicated that I have the same question in that post.  Any idea why we're getting the error: GetConsoleMode failed, LastError=|6|

    Thanks for looking at this.


  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 13, 2019 9:20AM

    I didn't look at your documentation links.  However I did install APEX in its own home directory (i.e. E:\apex182 )and I also installed ORDS  (E:\ORDS ) in its own home directory.  I know that seems like it shouldn't be done but the reason is that if I upgrade the Oracle 18c ,I do not overwrite the ORDS or APEX installs within it.  Folks on this forum seem to feel this is a good practice.  Maybe its worth trying that? 

    Second - rename that .properties file to something like .old and trying running things again.    Don't reference it when you start up ORDS the first time.  I know I mentioned that but that file can be troublesome.  Try to get it to run without it until its up and running.

    I did not need to manually create the APEX_LISTENER or APEX_REST_PUBLIC_USER accounts.  I'm using Oracle 18c as my database.  If you are using Oracle 12 maybe they are not there by default?  I can't recall.

    Another useful script that you may find yourself using at some point is reset_image_prefix.sql.

  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 13, 2019 10:33AM

    By the way apex_rest_config.sql creates the APEX_LISTENER and APEX_REST_PUBLIC_USER.  You should not need to do that using APEX 18.2.  I just looked at the .sql file.  If you are using pluggable databases make sure you ran it in the correct place.

  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 13, 2019 10:40AM

    Sorry I had to correct that in my original post after looking at my documentation.  You probably read it before I finished editing it. 

  • Thompson
    Thompson Member Posts: 25 Blue Ribbon
    edited Mar 13, 2019 2:28PM

    I pointed it to the images directory under E:\apex182 not the oracle db home.  In my case it was E:\apex182\apex\images