Forum Stats

  • 3,826,570 Users
  • 2,260,666 Discussions
  • 7,897,003 Comments

Discussions

ORA-12560: TNS:protocol adapter error after successful installation of 18 xe

2»

Answers

  • SullivanK
    SullivanK Member Posts: 16 Blue Ribbon
    edited Mar 18, 2019 11:08AM Answer ✓

    Guess we found it.

    My home laptop is Win Home edition.

    https://docs.oracle.com/en/database/oracle/oracle-database/18/ntdbi/oracle-database-software-requirements.html#GUID-CEF2…  says that is not supported, only Pro, Enterprise, and Education editions so I'm out of luck.

    Would be nice if the installer could check this as well.

    Thanks for your help Christian.

  • SBiedrzycki
    SBiedrzycki Member Posts: 5
    edited Mar 19, 2019 4:13PM

    I'm not entirely sure that the Windows edition is related.  I've actually spent the day wrestling with installing the XE with no luck.  I get the same error but I'm on Win 10 Pro.  Notable difference in my case is that I don't even have the recovery service even.  Only service running is the TNS listener. 

    I also tried working around the problem by directly configuring a new DB with DBCA but have brickwalled at another issue with error [DBT-50000] Unable to check for available memory. 

    Otherwise, my installation approach was the same.  Ran Setup as Administrator from my normal user account which is part of the Administrators group.  Installation completed successfully.  Same error when attempting to login through sqlplus.  I had no prior Oracle installations on the system.  Problem was reproducible through uninstall, reinstall with restarts in between to ensure cleanup.

    SullivanK