Forum Stats

  • 3,740,575 Users
  • 2,248,276 Discussions
  • 7,861,333 Comments

Discussions

SQLcl on Linux: cursor keys and tab key don't work

User_E4DJL
User_E4DJL Member Posts: 8 Red Ribbon
edited Aug 26, 2019 8:41AM in SQLcl

Running SQLcl 19.2.1 on Ubuntu 19.04: I can start SQLcl without any issue but on connecting, the cursor and tab keys don't work. No beep, no error, just not working. Anyone who can help?

openjdk version "12.0.2" 2019-07-16

Answers

  • Gaz in Oz
    Gaz in Oz Member Posts: 3,777 Bronze Crown
    edited Aug 25, 2019 11:26PM

    This is likely more of a ubuntu issue than a sqlcl isue.

    . Do the <TAB> key and cursor keys behave as expected in the shell (BEFORE starting sqlcl)?

    . What shell are you in/using?

      $  echo $SHELL

    bash will be the most likely shell to behave "properly" with no changes on your part.

    If it is not bash, you can change it by:

      $ sudo chsh -s /bin/bash <username>

    . Does the <TAB> and the cursor keys behave as expected in the shell now?

              up/down should show previous/next commands you've executed in this shell. <TAB> is auto-complete/show files in current directory.

    If that's working, try starting sqlcl "now" and see how you go.

    If that doesn't fix your keys, then perhaps other answers here may help:

    https://askubuntu.com/questions/325807/arrow-keys-home-end-tab-complete-keys-not-working-in-shell

  • User_E4DJL
    User_E4DJL Member Posts: 8 Red Ribbon
    edited Aug 26, 2019 6:47AM

    I figured it out finally via strace: SQLcl uses the readline library and reads ~/.inputrc. In particular SQLcl doesn't cope with assigning "menu-complete" to the Tab key and history-search-backward/history-search-forward to the cursor keys. I tried setting $INPUTRC to /dev/null for SQLcl but this didn't work. At least I know now what's going on.

  • Gaz in Oz
    Gaz in Oz Member Posts: 3,777 Bronze Crown
    edited Aug 26, 2019 6:59AM

    Works fine on CentOS7 and connecting to the linux server with putty, so sqlcl isn't the issue.

  • User_E4DJL
    User_E4DJL Member Posts: 8 Red Ribbon
    edited Aug 26, 2019 8:31AM

    You need a ~/.inputrc with the following lines to demonstrate the issue:

    "\t": menu-complete

    "\eOA": history-search-backward

    "\eOB": history-search-forward

  • User_E4DJL
    User_E4DJL Member Posts: 8 Red Ribbon
    edited Aug 26, 2019 8:41AM

    The cursor key code might depend on your terminal. But the "\t" should work regardless of the terminal emulator.

    sql /nolog

    sele<TAB>

    will complete to SELECT without menu-complete set and will do nothing with menu-complete set.

  • Kelly Clowers
    Kelly Clowers Member Posts: 1 Green Ribbon

    Would be really nice to get a bug fix for this. Confirm that if

    "\eOA": history-search-backward

    "\eOB": history-search-forward

    (or the VT220 equivalents, "\e[A" and "\e[B")

    are set in .inputrc, history access in sqlcl does not work with up and down arrows

    Those bindings allow context sensitive history in e.g. Bash - ls [up] will go to the previous command that started with ls

    I don't necessarily need the sqlcl history to be context sensitive, I just need the arrow keys to still work at all.


    A workaround could be to use a shell script wrapper that does

    bind -r "\e[A"; bind -r "\e[B"

    before invoking sqlcl, this unbinds the up and down arrows and then they work in sqlcl (or the eOA eOB versions if that is what you use)

Sign In or Register to comment.