Forum Stats

  • 3,874,905 Users
  • 2,266,789 Discussions


How can I Make SQL Developer Data Modeler Work on MacOS Big Sur?

My Oracle Data Modeler worked fine on my MacOS company laptop. Then the latest MacOS 11.1 (code name Big Sur) was installed and now Data Modeler won't open. Will Oracle provide a fix for SQL Developer Data Modeler to work on the Big Sur OS? Is there any way I can retrieve all my models that were created before the OS update?



  • Peter de Vaal
    Peter de Vaal Member Posts: 174 Bronze Badge

    Did you check you still have the Java version installed that is expected by Data Modeler? It might be that a BigSur install removes Java. I cannot test unlucky enough, my MBP is just a few months too old to upgrade to BigSur.

  • IsaacW
    IsaacW Member Posts: 5 Blue Ribbon

    No I did not check the previous Java. I'll do that now. Thank you.. However, I did download the newest Data Modeler along with its specified Java. When I attempt to launch it, BigSur returns a message stating "'Oracle Data Modeler' can't be opened because Apple cannot check it for malicious software.". That tells me that Data Modeler for MacOS has not yet been upgraded. I'm hoping there will be some way to save/retrieve my models in the future.

  • Peter de Vaal
    Peter de Vaal Member Posts: 174 Bronze Badge

    DataModeler runs as SQL developer on Java, so may have the same solutions. On the SQL Dev discussions several solutions have been mentioned, see e.g.:

  • User_CI4SM
    User_CI4SM Member Posts: 2

    I have the correct Java, have modified the conf files... got it running, created a very small 1 entity model and tried to save. Get an error saying the fold (/Users/[myname])... anythingunder that is not Accessible.

    Datamodeler listed in "All folders" access. Perms onall dirs/folders have been opened up. My is owner etc. etc. (I'm a very experience UNIX etc . admin). Driving me crazy... also going nuts with the latest Windows version and the "Msvcr100.dll" file.

    I have a fortune 150 client ready to look at this (and other Oracle products) for ETL/Data profiling, Meta data etc. I have until Monday (12/14) to get this working or they'll be spending on ErWin or ErStudio.

    PS 27" iMac, latest Big Sur, 64 GB ram etc. etc

    Windows is similar.. It shouldn't be this difficult


  • User_CI4SM
    User_CI4SM Member Posts: 2


    Thank you for the quick response 'll try it later this afternoon . On the Mac Ios, I will just have to save everything under 'public' until the product is compatible with Big Sur. I shudder to think of the issues looming with Apple's new chipset and compatibility. ;-)

  • Did you get Data Modeler working? I posted on the SQL Developer form but will re-post here for convenience:

    I'm still unable to get Data Modeler to launch. I downloaded SQL Developer, in the hopes of figuring it out and sure enough, SQL Developer had the same issue, but with the article you linked to above (@thatJeffSmith-Oracle posted it - I've not been around long enough to post links; great summary and fixed SQL Developer just not Data Modeler), I was able to get it working by changing the SetJavaHome path in the product.conf file.

    SetJavaHome /Library/Java/JavaVirtualMachines/jdk-11.0.10.jdk/Contents/Home

    I didn't see a hidden directory for Data Modeler at first but after downloading SQL Developer, I saw:

    /Users/<username>/.oraclesqldeverloperdatamodeler. In hopes the same fix would work, I changed the SetJavaHome in:


    also to

    SetJavaHome /Library/Java/JavaVirtualMachines/jdk-11.0.10.jdk/Contents/Home

    But that did not work. When I try to run it, I can see it pop up briefly in Force Quit Applications but it immediately disappears. 

    If I try to run it from the command line, I get this:

    ➜ MacOS bash

    /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home line 9: cd: Not a directory

    In System Preferences / Security & Privacy in the bottom panel under "Allow app from", I have "App Store and identified developers" checked.

    I have Java installed:

    ➜ MacOS java -version

    java version "11.0.10" 2021-01-19 LTS

    Java(TM) SE Runtime Environment 18.9 (build 11.0.10+8-LTS-162)

    Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.10+8-LTS-162, mixed mode)

    ➜ MacOS /usr/libexec/java_home


    Thanks for any help on this!

  • user5876769
    user5876769 Member Posts: 6 Blue Ribbon
    edited Feb 12, 2021 10:58PM

    I've been struggling for 2 days now - same bloody error javafx.base not found when I run from Applications/ on Big SUR.

    Discovered the following:

    SqlDeveloper 20.4 creates `~/.sqldeveloper/20.4.0/product.conf and works with SetJavaHome set to JDK11 path.

    Data Modeler acts differently.

    Data Modeler Version build 374.0801 creates ~/.oraclesqldeveloperdatamodeler/19.5.0/product.conf even for version 20.4 at this time.

    Could not get JDK 11 to work, dumps java.lang.module.FindException: Module javafx.base not found

    Changed SetJavaHome to JDK 8.

    SetJavaHome /Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home

    Voila !!!!

  • user5876769 you are my new favorite person! Changing the JDK from 11 to 8 did the trick. I can even run it normally now by clicking on the icon :)

    Thank you!!! Thank you!!! Thank you!!!

    To summarize my issue: Oracle data modeler would not open (or open and immediately close; you could see the process immediately quit). I was able to get SQL Developer to work by changing the JDK in the Product.conf file. I changed that same line in the Oracle Data Modeler product.conf file to JDK 11 but it had no effect. But changing to JDK 8 did work.

    If you have this problem on Mac OS Big Sur, try this:

    Find the JDKs you have installed (download JDK 8 if you don't have it) by listing them here:


    ➜ JavaVirtualMachines ls -l

    total 0

    drwxr-xr-x 3 root wheel 96 Jan 29 07:18 jdk-11.0.10.jdk

    drwxr-xr-x 3 root wheel 96 Aug 10 2020 jdk-11.0.8.jdk

    drwxr-xr-x 3 root wheel 96 Aug 11 2020 jdk1.8.0_261.jdk

    ➜ JavaVirtualMachines

    Since I have JDK1.8.0_261.jdk installed, I used that in the product.conf file here:


    and uncommented and modified line 20 so it became this:

    SetJavaHome /Library/Java/JavaVirtualMachines/jdk1.8.0_261.jdk/Contents/Home

    Thanks again user5876769!!

  • Niall
    Niall Member Posts: 33 Blue Ribbon

    Thanks. This worked for me :)

    It wasn't working with the jdk-11.0.9.jdk that I use for SQL Developer - so I had to download and install jdk1.8.0_281.jdk.

    I changed the product.conf and then it worked.

    (Mac Mini M1 with Big Sur)