Forum Stats

  • 3,875,958 Users
  • 2,267,000 Discussions


SQL Developer 20.4 will not start on Windows 10

User_OWSM5 Member Posts: 1 Green Ribbon

Have been fighting with this for a while. I have tried with the download packages that include the JRE, those that don't, the 32 bit version, installing in different locations (Program Files vs my project folder) and when I click on the exe, it seems to run for couple seconds and then just goes away. I never get any error or indication of anything happening.

Following instructions on other threads on this site, I ran the exe from the command line in BIN and got:

java.lang.module.FindException: Module jdk.jdi not found

I have verified that I have JRE 1.8:

C:\>java -version

java version "1.8.0_281"

Java(TM) SE Runtime Environment (build 1.8.0_281-b09)

Java HotSpot(TM) 64-Bit Server VM (build 25.281-b09, mixed mode)

I have seen some other posts about removing the JDK and just leaving the JRE, but unsure if I will need the JDK for other apps.

I have also uninstalled the JRE (including old versions) and reinstalled it.

My most recent extract/install was to Program Files/sqldeveloper, but it behaves the same as when I tried to run it from a project folder in My Documents.

At a bit of a loss as where to investigate next. Thanks for any pointers



  • cormaco
    cormaco Member Posts: 2,046 Silver Crown

    A JRE is not sufficient to run SQL Developer, you need either Oracle JDK 8 or 11.

    The download with the bundled JDK should run out of the box.

  • User_PKA23
    User_PKA23 Member Posts: 0 Green Ribbon

    Yo tengo el mismo problema y no se resuelve de ninguna forma, ni se indica el error. No se que hacer.

  • thatJeffSmith-Oracle
    thatJeffSmith-Oracle Distinguished Product Manager Posts: 8,883 Employee

    If you're on windows, use the BIGGEST zip, that includes the JDK.

    "Windows 64-bit with JDK 8 included Download(423 MB)"

  • User_OWSM5
    User_OWSM5 Member Posts: 1 Green Ribbon

    I finally got it to fun from within the big download, after deleting the user info folder. There are instructions in other posts here. Thanks everyone.

  • sabari
    sabari Member Posts: 1 Blue Ribbon

    I faced the same problem wherein SQL Developer was running only as Administrator and not in my login in Microsoft Windows 10 Pro. Got it resolved after I deleted C:\Users\<windows login name>\AppData\Roaming\SQL Developer\ folder.

  • User_T5TYG
    User_T5TYG Member Posts: 1 Green Ribbon

    I had similar issue. I had tried both the x64 (with JDK) and the x86. When I clicked on the sqldeveloper.exe, nothing came up but when I checked the Task Manager, it was running. This puzzled me a lot. I've watched videos and it should be very straightforward. I'm trying to figure out what I did or what was on my computer that's preventing from popping up. Finally, I tried to extract the file using 7-Zip, it finally worked. Previously, I just used the Windows built-in Extract ALL to extract the zipped file downloaded from Oracle but when I clicked on the sqldeveloper.exe, nothing came up.

    I am using Windows 10 20H2.