Forum Stats

  • 3,872,731 Users
  • 2,266,464 Discussions
  • 7,911,287 Comments

Discussions

Unknown error while document upload. 1 error has occurred Error:

Bansi
Bansi Member Posts: 9 Green Ribbon

Hi, I've created report with form for document upload.

first, there is one button which is redirecting to document report page (model dialog) and then report to form. in which I've passed document id from button target set items to item named id on report and then item named id from report to form page. on form page, id item is display only with list of value.

On form page, I am saving document directly in table without using apex temp files table.

file browse item settings: display as : inline file browse, storage type: blob column specified in item source attribute , mime type, filename, charset, last updated column all are as per table columns.

While uploading the document, sometimes it's showing this unknown error and sometimes allowing to upload.


I have already tried some testcases like size related and extension related

I'm not able to understand what exactly the error is about.

Please help.

Thank you.

Answers

  • Hamza Al-abbasi
    Hamza Al-abbasi Member Posts: 770 Bronze Crown

    This is unnormal behavior. Can you reproduce this on apex.oracle.com?

  • Bansi
    Bansi Member Posts: 9 Green Ribbon
    edited Apr 25, 2022 9:29AM

    @Hamza Al-abbasi Yes, I have already tried on apex.oracle.com, where everything is working fine.

    one more thing, I am getting this error in the Production environment side, where the development side it's working without any error.

    error in console: POST : .../apex/wwv_flow.accept 404

    in response tab:

    {    "code":  "NtAuthorizedOrNotFound",      "title":  "Procedure not authorized or not found",      "message":  "The procedure named wwv_flow.accept could not be accessed or found",      "o:errorCode":   "ORDS-22001",      "cause":    "The procedure may not be declared, or the user executing this request may not have been granted",     "action":   "Check the spelling of the procedure, check the execute privilege has been granted to the caller and check the configured security.",   "type":   "tag.oracle.com,2020:error/NotAuthorizedOrNotFound" }
    

    Please advise, how to overcome this problem?

    Thanks.