Forum Stats

  • 3,851,779 Users
  • 2,264,024 Discussions
  • 7,904,848 Comments

Discussions

Oracle Database XE 21c cannot create database

I am installing an Oracle Database XE 21c in Windows 64bit architecture. Youtube installation looks easy but mine did fail on database creation!

I am invoking a DBCA tool and I am encountering a memory configuration issue. Database XE max should be 2GB for both SGA and PGA but dbca does not allow me to continue with less than 2GB else it fails. And when I put more than 2GB, it will ask for more and says ORA-00821: Specified value of SGA_target 2096M is too small, needs to be atleast 2240M.

I need help, been working on this for quite a while. Thanks in advance.

Tagged:
«1

Answers

  • User_GMSNN
    User_GMSNN Member Posts: 5 Green Ribbon
    edited Jan 25, 2022 9:02PM

    I have the same error on Windows 10 Pro, Dell Precision 7810, 32 GB memory,

    2 CPU x 8 Cores x 2 threads = 32 threads...

  • User_81UY9
    User_81UY9 Member Posts: 4 Red Ribbon

    any progress on your installation? @User_G0FB5@User_GMSNN

  • Is error occurring during the installation of XE, or after it is completed?

    Did you receive an error during installation?

  • User_GMSNN
    User_GMSNN Member Posts: 5 Green Ribbon
    edited Feb 14, 2022 6:28PM
    ORA-00821 occurs during installation, and it is impossible to connect to the database
    using sqlplus as sysdba "sqlplus / as sysdba".
    
  • User_81UY9
    User_81UY9 Member Posts: 4 Red Ribbon

    @Christian.Shay -Oracle,I encountered during the installation and will not able to complete due to  ORA-00821: Specified value of SGA_target 2096M is too small, needs to be atleast 2240M. I am installing on Windows 64 bit with 64gb of RAM.

  • User_81UY9
    User_81UY9 Member Posts: 4 Red Ribbon

    The problem is it won't allow me to create a database with more than 2GB RAM of PGA+SGA(Database Express limitation) but it won't allow me to create with too small SGA for shared pool size. I have 64GB of RAM in my machine, running MS Windows SQLServer 2019

  • User_GMSNN
    User_GMSNN Member Posts: 5 Green Ribbon
    edited Jan 25, 2022 4:33PM

    ...product\21c\cfgtoollogs\dbca\XE\XE.log :

    ----------------------------------------------------------------------------------------------------------------

     2022-01-24 22:01:34.262 CST ] Prepare for db operation

    DBCA_PROGRESS : 7%

    [ 2022-01-24 22:01:39.199 CST ] Copying database files

    DBCA_PROGRESS : 8%

    [ 2022-01-24 22:02:00.239 CST ] [WARNING] ORA-00821: Specified value of sga_target 1536M is too small, needs to be at least 1600M

    ORA-01078: failure in processing system parameters

    DBCA_PROGRESS : 9%

    [ 2022-01-24 22:02:00.239 CST ] [FATAL] ORA-01034: ORACLE not available

    ... and so on ...

  • User_7CH7A
    User_7CH7A Member Posts: 1 Red Ribbon

    Any word on this? I have the exact same problem. Seems to be high-memory machines. I have Windows 10 Pro for Workstations... 32-core, 48GB RAM.

  • User_GMSNN
    User_GMSNN Member Posts: 5 Green Ribbon
    edited Feb 14, 2022 6:47PM

    /************************

    ** Solution was found: **

    ************************/

    1) "Start button" -> Find [Control Panel] -> [System Configuration] -> [Boot] folder.

    2) Click [Advanced Options...] button. In the form "Boot Advanced Options"

    check the "[ ] Number of processors " checkbox, then select number of CPUs (about 8). Save your changes.

    (Just in case - I selected 4 CPUs).

    4) Restart your PC.

    3) Install Oracle 21c XE database. Install process is to slow (took about 30 min), but without errors.

    4) When installation is done, check the services (using the command "lsnrctl status").

    Services "XE", "XEXDB", "XEPDB1" have to work.

    5) Go go [Advanced Options...] of your PC (see item#2) and UNCHECK the "[ ] Number of processors " checkbox. Save your changes.

    6) Restart your PC. Database will work as expected.

    7) Enjoy :)

  • User_YJECZ
    User_YJECZ Member Posts: 1 Green Ribbon

    @User_GMSNN THANK YOU!!! this worked for me. I have a ryzen 5950x with 16cores and I bumped it down to 4 for the install. The errors I was getting was mostly about TNS, but turns out the database wasnt installed correctly and the installer did not tell me.

    User_GMSNN