Forum Stats

  • 3,814,139 Users
  • 2,258,824 Discussions
  • 7,892,587 Comments

Discussions

Parameterizing the target base URL (e.g. Domain name) in e-Test scripts

user9528974
user9528974 Member Posts: 8
edited Jul 8, 2008 11:16AM in QA/Testing
Hi there,

I am currently building all my functional tests (scripts) using e-Test, given a target TG1 machine with URL (http://www.myfirsturl.com)

Later I am planning to run these tests against another target TG2 environment, let us say (http://www.mysecondurl.com).

Is there a way to do easily it, thus avoiding the need to re-record all tests again (i.e. if the target system changes)?

Many thanks,

Nuno

Comments

  • 644275
    644275 Member Posts: 15
    You can use Script Updater Utility (Programs - eTester - Script Updater) to update all your URLs. If you just change it on the first page, the new URL will be used for all the other pages, even if you don't see the new URL in the Address Properties for the other pages in the scripts.
  • Hi,

    Hum it seems that I currently do not have it installed...was it supposed to be installed on the "e-TEST suite" program group (available from the Start menu)?

    I only have e-Tester installed and no "e-Manager" or "e-Load" has been installed...
  • 644275
    644275 Member Posts: 15
    Yes, it should be available as part of the eTester group of products. You have to check the checkboxes for these products when you are installing eTester. Also, eManager and eLoad need separate licenses than eTester. Script Updater is a new Utility that is available with eTester 8.2. So if you have an older version, you will not see it. There are other ways to change URLs, using VBA, so if you cannot find Script Updater or can't upgrade to 8.2, you can try them.

    Do you have access to the Archived Empirix Forum? There are some threads that deal with this issue.
  • user9528974
    user9528974 Member Posts: 8
    edited Jul 8, 2008 11:16AM
    Hi again,

    thanks a lot for your quick response!!

    Actually, I have e-Tester V8.20 installed...I must have forgotten to click the check box during installation....

    Anyway, tomorrow or something I am going to install the latest version of e-Tester (made available by Oracle - 8.30 - I think) and will also install e-Load and e-Manager on an additional machine....I'll keep your suggestion in mind, so that I don't forget to add the Script Updater Utility...

    Thanks again for your quick responses,

    Gizmo
This discussion has been closed.